summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-26 18:29:58 +0000
committerSam James <sam@gentoo.org>2020-11-26 18:34:16 +0000
commitb90b266ba21562b104680ffe4847e14442dcb871 (patch)
treeb999c13aa8529ea47d8a081577d74b211e8e3c97 /dev-libs/pugixml
parentsci-libs/ignition-math: Drop 4.0.0-r1 (diff)
downloadgentoo-b90b266ba21562b104680ffe4847e14442dcb871.tar.gz
gentoo-b90b266ba21562b104680ffe4847e14442dcb871.tar.bz2
gentoo-b90b266ba21562b104680ffe4847e14442dcb871.zip
dev-libs/pugixml: bump to 1.11
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/pugixml')
-rw-r--r--dev-libs/pugixml/Manifest1
-rw-r--r--dev-libs/pugixml/pugixml-1.11.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/pugixml/Manifest b/dev-libs/pugixml/Manifest
index dbf5dcb05798..3772ba893d9c 100644
--- a/dev-libs/pugixml/Manifest
+++ b/dev-libs/pugixml/Manifest
@@ -1,2 +1,3 @@
DIST pugixml-1.10.tar.gz 381990 BLAKE2B ea446d11fe5213a5250b7e737a9e80a3976454724e1a1c326b689214ad4d3e183abd417a7782b3d5c68a0aabce42228e121352e4d2dd33f5f2bb2334f6c72c27 SHA512 bfc80661005d0a0fb82ca6d5299e5efdd1bb468e11ee52d7ee9367e15776d28efb60266ce03842715cd43aae023afc2b369797bb3cbecd6d6a65c3ae3903e469
+DIST pugixml-1.11.tar.gz 385889 BLAKE2B e3acd45c396f56e4bd4d265f4fcb68fd5c8127acc5aaaf147ff7d50ac8340cef14b31369ca09762f1d3be9781b13f30a6976244cf99bdb4aec6f737e7bf9413d SHA512 a559be72910dc6d9d74c32f1b5389b173bc92858f627e61007a5f2284da251d8511e08571b870e7c6ce6e18cf42ef42fdb10f8b30b608067b452ccb9105d5ade
DIST pugixml-1.9.tar.gz 377369 BLAKE2B 39b5b0d63a20e9c15c5634e56f82207aed63843d252900db94dbf06d100d03916a16523ccb9de433cc94ded4a9e9d1dc11f47bfd6fd75e348a9a2af31c305db6 SHA512 853a9d985aae537391c6524d5413ef4de237d99d96cc58ea7fe7152f786df1e408cdacd2e4387697e23c3e67cdc1d42b29de554501309eae16d86edd0e24785f
diff --git a/dev-libs/pugixml/pugixml-1.11.ebuild b/dev-libs/pugixml/pugixml-1.11.ebuild
new file mode 100644
index 000000000000..0750359ebd79
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
+
+LICENSE="MIT"
+SLOT="0"