summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-07-21 21:31:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-21 23:46:13 +0200
commit9ee604e4e81767fe79224738ef7e1430f20f5b83 (patch)
tree87e7f69e4903744b969e2a29de668529dd4ec8cd /dev-libs/nmeap
parentnet-im/spectrum2: use correct python eclass (diff)
downloadgentoo-9ee604e4e81767fe79224738ef7e1430f20f5b83.tar.gz
gentoo-9ee604e4e81767fe79224738ef7e1430f20f5b83.tar.bz2
gentoo-9ee604e4e81767fe79224738ef7e1430f20f5b83.zip
dev-libs/nmeap: drop old version
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12502 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/nmeap')
-rw-r--r--dev-libs/nmeap/nmeap-0.3.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/nmeap/nmeap-0.3.ebuild b/dev-libs/nmeap/nmeap-0.3.ebuild
deleted file mode 100644
index 0a0e61c6988e..000000000000
--- a/dev-libs/nmeap/nmeap-0.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Extensible NMEA-0183 (GPS) data parser in standard C"
-HOMEPAGE="http://nmeap.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc"
-
-DEPEND="doc? ( app-doc/doxygen )"
-
-src_prepare() {
- default
-
- # Repsect users CFLAGS for the static lib archive
- sed -i -e 's/CFLAGS =/CFLAGS +=/' -e 's/-g -O0 -Werror//' src/Makefile || die
-
- # Don't build test programs, they are not needed
- sed -i -e '/TST/d' Makefile || die
-
- # Silent output of Doxygen and update it, since it is quite old
- if use doc; then
- sed -i -e 's/QUIET.*/QUIET = YES/' Doxyfile || die
- doxygen -u Doxyfile 2>/dev/null || die
- fi
-}
-
-src_compile() {
- local myemakeopts=(
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- )
-
- emake "${myemakeopts[@]}"
-
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- dolib.a lib/libnmeap.a
-
- doheader inc/nmeap.h inc/nmeap_def.h
-
- if use doc; then
- local HTML_DOCS=( "doc/tutorial.html" "doc/html" )
- fi
-
- einstalldocs
-}