summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-08-16 10:24:02 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-08-16 16:13:10 -0400
commit46560543c9d48506feb83de473a7b0bd0298ae83 (patch)
treea2e7634fbf6a0ab6d2cdac7b42f6a86daa9cc758 /dev-libs/mathjax
parentapp-doc/mathjax-docs: add 3.2.2 (diff)
downloadgentoo-46560543c9d48506feb83de473a7b0bd0298ae83.tar.gz
gentoo-46560543c9d48506feb83de473a7b0bd0298ae83.tar.bz2
gentoo-46560543c9d48506feb83de473a7b0bd0298ae83.zip
dev-libs/mathjax: add 3.2.2
Closes: https://bugs.gentoo.org/837722 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-libs/mathjax')
-rw-r--r--dev-libs/mathjax/Manifest1
-rw-r--r--dev-libs/mathjax/mathjax-3.2.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/mathjax/Manifest b/dev-libs/mathjax/Manifest
index ebad0abcc862..4fcea49fca3c 100644
--- a/dev-libs/mathjax/Manifest
+++ b/dev-libs/mathjax/Manifest
@@ -1 +1,2 @@
DIST mathjax-2.7.7.tar.gz 25347766 BLAKE2B c1f11bc854c95888d7f04ee627094a2e297e7554b0380dab30c08e2c4405495df611b440da0efd1e6456150513e07fa4ef90808d2332f9fb83785c118228de18 SHA512 471bd22475827a13d79de7d335f3e51ace06dfc04f575e8829b4505f428949f1dbe58798635cb434ed02ae0cd3fd8d1d577196b4961365fbcb399cc075d3284f
+DIST mathjax-3.2.2.tar.gz 6191341 BLAKE2B 4884ad28ede1d3d6f6647e04c8a69185a53715db673d42935ea9ff3ea1756e0e478b1f19345a35902d2e5c01a312272a2fe96dd36871cd8c4f266bcf4fb56c72 SHA512 4dc80c9e24593c1fcf08f38bad5251025f1de364d5cf24dd2f4cee0d78917dd11187f6132b67a17ff190d0a1862b83eb6c6edf28f91e8e84e50cdf76537f6b20
diff --git a/dev-libs/mathjax/mathjax-3.2.2.ebuild b/dev-libs/mathjax/mathjax-3.2.2.ebuild
new file mode 100644
index 000000000000..9d8ec2feb032
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-3.2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vcs-clean
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="https://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/MathJax-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+RDEPEND="doc? ( ~app-doc/mathjax-docs-${PV} )"
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_install() {
+ local DOCS=( CONTRIBUTING.md README.md )
+ default
+
+ if use doc; then
+ # We need best_version to determine the right revision for
+ # app-doc/mathjax-docs.
+ local docsPF=$(best_version app-doc/mathjax-docs)
+
+ # Strip the (known) category from the best_version output.
+ docsPF=${docsPF#app-doc/}
+
+ dosym "../${docsPF}/html" "/usr/share/doc/${PF}/html"
+ fi
+
+ insinto "/usr/share/${PN}"
+
+ # Start the install beneath the "es5" directory for compatibility with
+ # Arch, Solus, and Void Linux.
+ doins -r es5/*
+}