summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-08-24 23:23:22 +0800
committerYixun Lan <dlan@gentoo.org>2024-08-29 23:53:17 +0000
commit7d54d1dc3397d96ff966101d843260e8a23df897 (patch)
tree7b62011a40dde7e8bcb369bff3e62e3d8e80ae42 /dev-libs/marisa
parentapp-office/libreoffice-bin-debug: Stabilize 7.6.7.2 x86, #938703 (diff)
downloadgentoo-7d54d1dc3397d96ff966101d843260e8a23df897.tar.gz
gentoo-7d54d1dc3397d96ff966101d843260e8a23df897.tar.bz2
gentoo-7d54d1dc3397d96ff966101d843260e8a23df897.zip
dev-libs/marisa: enable py3.12, also drop py3.9
Closes: https://bugs.gentoo.org/909909 Closes: https://bugs.gentoo.org/929426 Closes: https://github.com/gentoo/gentoo/38279 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs/marisa')
-rw-r--r--dev-libs/marisa/marisa-0.2.6.ebuild10
-rw-r--r--dev-libs/marisa/marisa-9999.ebuild11
2 files changed, 10 insertions, 11 deletions
diff --git a/dev-libs/marisa/marisa-0.2.6.ebuild b/dev-libs/marisa/marisa-0.2.6.ebuild
index 6e587ffcb945..47f2023b5fad 100644
--- a/dev-libs/marisa/marisa-0.2.6.ebuild
+++ b/dev-libs/marisa/marisa-0.2.6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 2014-2023 Gentoo Authors
+# Copyright 2014-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517="setuptools"
DISTUTILS_OPTIONAL="1"
DISTUTILS_EXT=1
@@ -16,9 +17,7 @@ fi
DESCRIPTION="Matching Algorithm with Recursively Implemented StorAge"
HOMEPAGE="https://github.com/s-yata/marisa-trie https://code.google.com/archive/p/marisa-trie/"
-if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
-else
+if [[ "${PV}" != "9999" ]]; then
SRC_URI="https://github.com/s-yata/marisa-trie/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
@@ -30,6 +29,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="python? (
${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
dev-lang/swig
)"
DEPEND="python? ( ${PYTHON_DEPS} )"
diff --git a/dev-libs/marisa/marisa-9999.ebuild b/dev-libs/marisa/marisa-9999.ebuild
index 7731d92f28e3..45c481f3fb3a 100644
--- a/dev-libs/marisa/marisa-9999.ebuild
+++ b/dev-libs/marisa/marisa-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 2014-2023 Gentoo Authors
+# Copyright 2014-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517="setuptools"
DISTUTILS_OPTIONAL="1"
DISTUTILS_EXT=1
@@ -16,20 +17,18 @@ fi
DESCRIPTION="Matching Algorithm with Recursively Implemented StorAge"
HOMEPAGE="https://github.com/s-yata/marisa-trie https://code.google.com/archive/p/marisa-trie/"
-if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
-else
+if [[ "${PV}" != "9999" ]]; then
SRC_URI="https://github.com/s-yata/marisa-trie/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="|| ( BSD-2 LGPL-2.1+ )"
SLOT="0"
-KEYWORDS=""
IUSE="python static-libs"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="python? (
${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
dev-lang/swig
)"
DEPEND="python? ( ${PYTHON_DEPS} )"