summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ltxml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ltxml')
-rw-r--r--dev-libs/ltxml/Manifest2
-rw-r--r--dev-libs/ltxml/ltxml-1.2.5.ebuild26
-rw-r--r--dev-libs/ltxml/ltxml-1.2.9.ebuild45
-rw-r--r--dev-libs/ltxml/metadata.xml10
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/ltxml/Manifest b/dev-libs/ltxml/Manifest
new file mode 100644
index 000000000000..73e31fdb1404
--- /dev/null
+++ b/dev-libs/ltxml/Manifest
@@ -0,0 +1,2 @@
+DIST ltxml-1.2.5.tar.gz 1081135 SHA256 5fd43d802a4f89be6f27ff47fb69f37a155911ad6580f39b26100e6afefd3762 SHA512 b8cb5a17a35748b3c3df25ea01b97d41443f34ae3e086fa8b13e46b10edb653ad66a236ec88350b85a1879135e899e097f067628afc4db294d04314d1fd85fcb WHIRLPOOL 26a80484fe3902b85ae3fa4ae67cb9fb02eebd30da25721ad10efbad3b08bad8a83665644e543d4ca43617dade007d44001c6cc46242a572aa9ac423b3709790
+DIST ltxml-1.2.9.tar.gz 304050 SHA256 bc28fcdf63be636e03076deeacba75255cd9281f40a3dfd65a8c04aa93242921 SHA512 1c0b965b7ed330069a23259bc937546a6a0eb639206a844b6c4d524acfaeb1ec6978467fa8e63c8430ca222cec04386368e7ce625ac829ea5be445e880b86ac9 WHIRLPOOL 5481ce9e5cff99efe1d6ed0d4dc35cd844fa450995cee63d078faca2b628ec6aae7b8014f62fa744a4662866f21b41d58db5bb539d52b259fb1dc66b404b519e
diff --git a/dev-libs/ltxml/ltxml-1.2.5.ebuild b/dev-libs/ltxml/ltxml-1.2.5.ebuild
new file mode 100644
index 000000000000..d0051b61a368
--- /dev/null
+++ b/dev-libs/ltxml/ltxml-1.2.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+S="${WORKDIR}/${P}/XML"
+DESCRIPTION="Integrated set of XML tools and a developers tool-kit with C API"
+HOMEPAGE="http://www.ltg.ed.ac.uk/software/xml/"
+SRC_URI=ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/${P}.tar.gz
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64 ppc x86"
+IUSE=""
+DEPEND="dev-lang/perl"
+PV_MAJ="${PV:0:1}${PV:2:1}"
+
+src_compile() {
+ econf || die "configure failed"
+ emake all || die "make failed"
+}
+
+src_install() {
+ einstall \
+ datadir=${D}/usr/lib/${PN}${PV_MAJ} \
+ MANDIR=${D}/usr/share/man \
+ || die "make install failed"
+}
diff --git a/dev-libs/ltxml/ltxml-1.2.9.ebuild b/dev-libs/ltxml/ltxml-1.2.9.ebuild
new file mode 100644
index 000000000000..801ed1a0a875
--- /dev/null
+++ b/dev-libs/ltxml/ltxml-1.2.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Integrated set of XML tools and a developers tool-kit with C API"
+HOMEPAGE="http://www.ltg.ed.ac.uk/software/xml/"
+SRC_URI=ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/${P}.tar.gz
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+PV_MAJ="${PV:0:1}${PV:2:1}"
+
+S=${WORKDIR}/${P}/XML
+
+pkg_setup() {
+ tc-export AR
+}
+
+src_prepare() {
+ sed -e '/CFLAGS=/s:-g::' \
+ -e '/CFLAGS=/s:-O2::' \
+ -i configure || die
+ sed -e 's/ar rv/$(AR) rv/' -i src/Makefile.sub.in || die
+}
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ emake -j1 install \
+ datadir="${D}"/usr/$(get_libdir)/${PN}${PV_MAJ} \
+ libdir="${D}"/usr/$(get_libdir) \
+ prefix="${D}"/usr
+}
diff --git a/dev-libs/ltxml/metadata.xml b/dev-libs/ltxml/metadata.xml
new file mode 100644
index 000000000000..542bd448e2ea
--- /dev/null
+++ b/dev-libs/ltxml/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>
+Integrated set of XML tools and a developers tool-kit with C API
+</longdescription>
+</pkgmetadata>