summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:59:02 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:59:02 +0200
commitb512e0ae66ce849ac8faf5e8ff85bc1c0c2cfef5 (patch)
treed286003d51eae3e55c7d4b740a5feb5d46995ac7 /dev-libs/log4cpp
parentdev-libs/libuv: drop multilib (diff)
downloadgentoo-b512e0ae66ce849ac8faf5e8ff85bc1c0c2cfef5.tar.gz
gentoo-b512e0ae66ce849ac8faf5e8ff85bc1c0c2cfef5.tar.bz2
gentoo-b512e0ae66ce849ac8faf5e8ff85bc1c0c2cfef5.zip
dev-libs/log4cpp: drop multilib, static-libs
No multilib or static-libs reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/log4cpp')
-rw-r--r--dev-libs/log4cpp/log4cpp-1.1.3-r2.ebuild (renamed from dev-libs/log4cpp/log4cpp-1.1.3-r1.ebuild)21
1 files changed, 8 insertions, 13 deletions
diff --git a/dev-libs/log4cpp/log4cpp-1.1.3-r1.ebuild b/dev-libs/log4cpp/log4cpp-1.1.3-r2.ebuild
index 286862cfccee..b20890c24690 100644
--- a/dev-libs/log4cpp/log4cpp-1.1.3-r1.ebuild
+++ b/dev-libs/log4cpp/log4cpp-1.1.3-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
DESCRIPTION="C++ classes for flexible logging to files, syslog and other destinations"
HOMEPAGE="http://log4cpp.sourceforge.net/"
@@ -13,7 +13,7 @@ S="${WORKDIR}/${PN}"
LICENSE="LGPL-2.1"
SLOT="0/5"
KEYWORDS="amd64 ~arm ppc ~riscv ~s390 x86"
-IUSE="doc static-libs test"
+IUSE="doc test"
RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-doc/doxygen )"
@@ -28,10 +28,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.1.3-fix-version.patch
)
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/log4cpp-config
-)
-
src_prepare() {
default
@@ -45,19 +41,18 @@ src_prepare() {
eautoreconf
}
-multilib_src_configure() {
+src_configure() {
# Bashisms call configure tests to malfunction / config.h to be misgenerated
# which then causes a build failure later on in the package (w/ GCC 12,
# anyway).
- CONFIG_SHELL="${BROOT}"/bin/bash ECONF_SOURCE="${S}" econf \
+ CONFIG_SHELL="${BROOT}"/bin/bash econf \
--without-idsa \
- $(multilib_native_use_enable doc doxygen) \
- $(use_enable static-libs static)
+ $(use_enable doc doxygen)
}
-multilib_src_install_all() {
- einstalldocs
+src_install() {
+ default
# Package installs .pc files
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}