summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/log4cplus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/log4cplus')
-rw-r--r--dev-libs/log4cplus/Manifest1
-rw-r--r--dev-libs/log4cplus/log4cplus-1.1.2.ebuild65
-rw-r--r--dev-libs/log4cplus/metadata.xml16
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/log4cplus/Manifest b/dev-libs/log4cplus/Manifest
new file mode 100644
index 000000000000..2a1fc06fd383
--- /dev/null
+++ b/dev-libs/log4cplus/Manifest
@@ -0,0 +1 @@
+DIST log4cplus-1.1.2.tar.bz2 541761 SHA256 c46d56c96873dcb525791b5ea639d1415e74b1de99d51b657336cb6ebb72ed93 SHA512 a3bb619a0c005c63b533fa95fafe6c772dfc1b85f9b9556264b75a458398b81c48c17813ea04d07e3ea902f3f5f604b59dac7922412c5d0e0339200a453515b7 WHIRLPOOL a5b5f35b970150677f3336b954fb0ceac74517ae620427908f2d93108f09021ccdbf58a4044cfa51178a6624dff88833d0ac4f6c52136441310535bb0d79a264
diff --git a/dev-libs/log4cplus/log4cplus-1.1.2.ebuild b/dev-libs/log4cplus/log4cplus-1.1.2.ebuild
new file mode 100644
index 000000000000..3779ba3658cb
--- /dev/null
+++ b/dev-libs/log4cplus/log4cplus-1.1.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="C++ port of the Log for Java (log4j) logging library"
+HOMEPAGE="http://log4cplus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}-stable/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="iconv test threads working-locale working-c-locale qt4"
+
+REQUIRED_USE="iconv? ( !working-locale !working-c-locale )
+ working-locale? ( !iconv !working-c-locale )
+ working-c-locale? ( !iconv !working-locale )"
+
+RDEPEND="iconv? ( virtual/libiconv )
+ qt4? ( dev-qt/qtcore:4 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO docs/unicode.txt"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e 's:tests::' Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable threads) \
+ $(use_with iconv) \
+ $(use_with working-locale) \
+ $(use_with working-c-locale) \
+ $(use_with qt4 qt)
+}
+
+src_test() {
+ cd tests/
+
+ for dir in appender customloglevel fileappender filter \
+ hierarchy loglog ndc ostream patternlayout performance priority \
+ propertyconfig timeformat; do
+ einfo "Running test \"${dir}_test\""
+ pushd "${dir}_test/" 1>/dev/null
+ ./${dir}_test || die "Running ${dir}_test failed!"
+ popd 1>/dev/null
+ done
+
+ if use threads; then
+ for dir in configandwatch thread; do
+ einfo "Running test \"${dir}_test\""
+ pushd "${dir}_test/" 1>/dev/null
+ ./${dir}_test || die "Running ${dir}_test failed!"
+ popd 1>/dev/null
+ done
+ fi
+}
diff --git a/dev-libs/log4cplus/metadata.xml b/dev-libs/log4cplus/metadata.xml
new file mode 100644
index 000000000000..ea1344140b41
--- /dev/null
+++ b/dev-libs/log4cplus/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <use>
+ <flag name="working-locale">Use C++'s std::locale for wchar_t &lt;-&gt; char conversions. See also log4cplus's unicode.txt documentation</flag>
+ <flag name="working-c-locale">Use the C99 locale facilities for wchar_t &lt;-&gt; char conversions. See also log4cplus's unicode.txt documentation </flag>
+ <flag name="iconv">Use inconv for wchar_t &lt;-&gt; char conversions. See also log4cplus's unicode.txt documentation</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">log4cplus</remote-id>
+ </upstream>
+</pkgmetadata>