summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-22 08:32:37 +0100
committerSam James <sam@gentoo.org>2024-10-22 08:33:15 +0100
commit4c858a2a78c61667d7eb323b21ebf6c91f5c0bd9 (patch)
tree3335dda04dde4e54a77f18fb07b9feac5e1966a6 /dev-libs/libxmlb
parentdev-libs/libxmlb: enable py3.13 (diff)
downloadgentoo-4c858a2a78c61667d7eb323b21ebf6c91f5c0bd9.tar.gz
gentoo-4c858a2a78c61667d7eb323b21ebf6c91f5c0bd9.tar.bz2
gentoo-4c858a2a78c61667d7eb323b21ebf6c91f5c0bd9.zip
dev-libs/libxmlb: fix python_check_deps
We don't need setuptools unless USE=introspection, match the dep. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libxmlb')
-rw-r--r--dev-libs/libxmlb/libxmlb-0.3.19.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-libs/libxmlb/libxmlb-0.3.19.ebuild b/dev-libs/libxmlb/libxmlb-0.3.19.ebuild
index ae5e6c693c48..80d5a69f4840 100644
--- a/dev-libs/libxmlb/libxmlb-0.3.19.ebuild
+++ b/dev-libs/libxmlb/libxmlb-0.3.19.ebuild
@@ -42,7 +42,7 @@ BDEPEND="
"
python_check_deps() {
- python_has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+ use introspection && python_has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
}
pkg_setup() {