summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-26 21:41:37 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-26 21:41:37 +0100
commit75a62f8133f164629233684db882f16eec2fe1ef (patch)
treeaa0741064acc48ae09ad77446f477ec1a591ee72 /dev-libs/libtommath
parentdev-libs/nanomsg: make tests sequential (diff)
downloadgentoo-75a62f8133f164629233684db882f16eec2fe1ef.tar.gz
gentoo-75a62f8133f164629233684db882f16eec2fe1ef.tar.bz2
gentoo-75a62f8133f164629233684db882f16eec2fe1ef.zip
dev-libs/libtommath: respect CC in src_test(), bug #547760
While at it added actual test execution. This package does not run 'make test' by default but only compiles ./test. Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/libtommath-1.0-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/libtommath/libtommath-1.0-r1.ebuild b/dev-libs/libtommath/libtommath-1.0-r1.ebuild
new file mode 100644
index 000000000000..157da4e5a9b6
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-1.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="highly optimized and portable routines for integer theoretic applications"
+HOMEPAGE="http://www.libtom.net/"
+SRC_URI="https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+
+src_prepare() {
+ # need libtool for cross compilation. Bug #376643
+ cat <<-EOF > configure.ac
+ AC_INIT(libtommath, 0)
+ AM_INIT_AUTOMAKE
+ LT_INIT
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ touch NEWS README AUTHORS ChangeLog Makefile.am
+ eautoreconf
+ export LT="${S}"/libtool
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+_emake() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ -f makefile.shared \
+ IGNORE_SPEED=1 \
+ LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
+ INCPATH="${EPREFIX}/usr/include" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake test_standalone
+ ./test || die
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+ # We only link against -lc, so drop the .la file.
+ find "${ED}" -name '*.la' -delete
+
+ dodoc changes.txt
+
+ use doc && dodoc *.pdf
+
+ if use examples ; then
+ docinto demo
+ dodoc demo/*.c
+ fi
+}