summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-14 02:38:49 +0100
committerSam James <sam@gentoo.org>2023-09-14 03:09:10 +0100
commite51dc9ea8ab9ada0c226fec4bb2dac373b6112f5 (patch)
tree4d956f61f9c1da078f96dd4a5779095a2dffb908 /dev-libs/libstrophe
parentkernel-build.eclass: pass INSTALL_MOD_STRIP in src_test (diff)
downloadgentoo-e51dc9ea8ab9ada0c226fec4bb2dac373b6112f5.tar.gz
gentoo-e51dc9ea8ab9ada0c226fec4bb2dac373b6112f5.tar.bz2
gentoo-e51dc9ea8ab9ada0c226fec4bb2dac373b6112f5.zip
dev-libs/libstrophe: avoid maintainer mode (again)
Just like in 191fbdaf985652a3873a545226a53cc2ad37de41, we need to use autoreconf because our patch touches Makefile.am. Also, drop shellcheck annotation. They have very little value at the moment and we really don't want the tree littered with these. There's some draft shellcheck support to teach it ebuilds and we can maybe revisit if/once that lands. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libstrophe')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.12.3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.12.3.ebuild b/dev-libs/libstrophe/libstrophe-0.12.3.ebuild
index bfa7f2b9db7f..b469005aab46 100644
--- a/dev-libs/libstrophe/libstrophe-0.12.3.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.12.3.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
HOMEPAGE="https://strophe.im/libstrophe/"
SRC_URI="
@@ -32,8 +34,14 @@ PATCHES=(
"${FILESDIR}/${PN}-0.12.3-allow-tests-when-static.patch"
)
+src_prepare() {
+ default
+
+ # tests patch touches Makefile.am, need to regenerate to avoid maintainer mode
+ eautoreconf
+}
+
src_configure() {
- # shellcheck disable=SC2207
local myeconf=(
--enable-tls
$(use_with !expat libxml2)