summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-29 02:12:35 +0100
committerSam James <sam@gentoo.org>2024-08-29 02:13:58 +0100
commit115f92066a228a599800d54b7f2cec768ea3bc9f (patch)
tree7e258d0a26750b038463b488dd29c297f5a847ae /dev-libs/libkdumpfile
parentdev-debug/drgn: fix dev-libs/libkdumpfile dep (diff)
downloadgentoo-115f92066a228a599800d54b7f2cec768ea3bc9f.tar.gz
gentoo-115f92066a228a599800d54b7f2cec768ea3bc9f.tar.bz2
gentoo-115f92066a228a599800d54b7f2cec768ea3bc9f.zip
dev-libs/libkdumpfile: drop Python bindings
The Python bindings in libkdumpfile itself are deprecated in favour of a separate CFFI set of bindings, but it turns out drgn doesn't even use the bindings at all, so we can drop these deprecated ones which couldn't be built in PEP517 mode. Closes: https://bugs.gentoo.org/938584 Fixes: 5fa70534e895c7a9b14bfca589fd862711a5cdff Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libkdumpfile')
-rw-r--r--dev-libs/libkdumpfile/libkdumpfile-0.5.4-r1.ebuild (renamed from dev-libs/libkdumpfile/libkdumpfile-0.5.4.ebuild)28
1 files changed, 7 insertions, 21 deletions
diff --git a/dev-libs/libkdumpfile/libkdumpfile-0.5.4.ebuild b/dev-libs/libkdumpfile/libkdumpfile-0.5.4-r1.ebuild
index fe48a9f877fc..a0f045ef6f41 100644
--- a/dev-libs/libkdumpfile/libkdumpfile-0.5.4.ebuild
+++ b/dev-libs/libkdumpfile/libkdumpfile-0.5.4-r1.ebuild
@@ -3,8 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..13} )
-inherit autotools python-r1
+inherit autotools
DESCRIPTION="Kernel coredump file access"
HOMEPAGE="https://github.com/ptesarik/libkdumpfile"
@@ -14,10 +13,8 @@ LICENSE="|| ( LGPL-3+ GPL-2+ )"
SLOT="0"
KEYWORDS="~amd64"
IUSE="lzo snappy zlib zstd"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
- ${PYTHON_DEPS}
lzo? ( dev-libs/lzo )
snappy? ( app-arch/snappy:= )
zlib? ( sys-libs/zlib )
@@ -40,32 +37,21 @@ src_prepare() {
}
src_configure() {
- # We could make Python optional in future as libkdumpfile's
- # builtin Python bindings appear deprecated in favour of another
- # CFFI-based approach, but given we're adding libkdumpfile for
- # dev-debug/drgn right now which uses *these*, let's not bother.
- local ECONF_SOURCE=${S}
local myeconfargs=(
+ # The Python bindings within libkdumpfile are deprecated
+ # and don't work w/ PEP517. There's a new CFFI bindings
+ # project we can use if anyone asks for them.
+ --without-python
$(use_with lzo lzo2)
$(use_with snappy)
$(use_with zlib)
$(use_with zstd libzstd)
)
- python_foreach_impl run_in_build_dir econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_test() {
- python_foreach_impl run_in_build_dir default
+ econf "${myeconfargs[@]}"
}
src_install() {
- python_foreach_impl run_in_build_dir default
- python_foreach_impl python_optimize
- einstalldocs
+ default
find "${D}" -name '*.la' -delete || die
}