summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-17 19:49:42 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-17 19:49:42 +0100
commitc1671e23e8605c1d1e951890c794f00fd1fb3959 (patch)
tree1092be9ab7f6f9a4df06923545675839fb6fd22c /dev-libs/libinput
parentapp-office/pinpoint: Drop old (diff)
downloadgentoo-c1671e23e8605c1d1e951890c794f00fd1fb3959.tar.gz
gentoo-c1671e23e8605c1d1e951890c794f00fd1fb3959.tar.bz2
gentoo-c1671e23e8605c1d1e951890c794f00fd1fb3959.zip
dev-libs/libinput: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.1.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 2b5d34bc79fb..cd33922a61b4 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -3,3 +3,4 @@ DIST libinput-0.9.0.tar.xz 510512 SHA256 309043976f41f5451c2a4b1c25bc2993b18aecb
DIST libinput-1.0.0.tar.xz 785056 SHA256 afbd2751c000a4e5833624b6177a6919ad259f0bca44093947421c885fd42c0f SHA512 b6fc7973982cb2826fc5beb514e954d7673023628739a86d18b2522b1ad0ecf55f9d6c83e6307c10c633c57d6b61227898aded6a22a2de536c0f14f27d23b903 WHIRLPOOL 13304875b753127ada76bf18ba56ea9828d6532db5eefce56439ede83eeeb43b6da6aa59f763d2c912de838221ee53fd7d02bf865e80316a24c412ea001d3043
DIST libinput-1.0.1.tar.xz 800244 SHA256 482fb35119b457ba65a8bebaa47e4f6b4dbd77e59c320014a22296847b7ff99e SHA512 17efc6ddd58aadcd30aecb4d1b8b6ad32f6f61c592f29b0a99aac7d49e5cb814038874d9e8996cd6726f15c58bf4239169564c650a3250a87a9ec6fd3110c5bb WHIRLPOOL 0bba6b4a58ca0020ebcbffe5675d75832b4ed67a350ca141d990f9db522a2eee942543f475d76c1f2b816b849074f4a50e30bcb3adc99bd4abdea1a43800a2d5
DIST libinput-1.1.0.tar.xz 802348 SHA256 673186ea2a0d2b695afaa9758834f9217b175774d9ae222e1b43ff63c663f582 SHA512 7f014eabed120c00fcd2d8748aed44a8ca31fd30bdda8b289ca63f7d1bebb9c49f1d508707fb0c4a5c7c4a37b58548efdff0e9b7761475f18e1cf787a80520e6 WHIRLPOOL 028518c20cfc6daa442dd92d04183a6575b95b1f4792a646ce42c09a7bc75e5bb469ca88b8cad89919c0814e00aa65178cc49c9dca6e9aad4ce997a94f9ba645
+DIST libinput-1.1.1.tar.xz 791276 SHA256 2de2b433ddc73ba1bfd4d309fd873d0ced6937cf1a7a94e4afbf18ddd8f8dd17 SHA512 3806e67a4530be71463b693076a64f210475d3487abc2848f5ee13b92b281c6e4950bdb754c6b9c090c51c5b8dd4e698b882ae325bdea78bb05e6b7399eb75f0 WHIRLPOOL 031af4cb17d51d2f888cdb3192ccb25e4b3eb22422aeda3e999fd215b3d5bba89782b1f4a5e0b95706bf6da2ffaf3cbc0b5078a1fa95433afd414b79826542de
diff --git a/dev-libs/libinput/libinput-1.1.1.ebuild b/dev-libs/libinput/libinput-1.1.1.ebuild
new file mode 100644
index 000000000000..26877357fe85
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}