summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-03-06 15:46:32 -0500
committerDavid Seifert <soap@gentoo.org>2017-03-07 22:56:58 +0100
commita7bb963c619741bbc4e00331c93fb50f60f1faef (patch)
tree08c922700a506f21d34d197b2c13034511dcb8b9 /dev-libs/libfmt/libfmt-9999.ebuild
parentdev-java/icedtea-bin: Version bump to 7.2.6.9 wrt security bug #609562 (diff)
downloadgentoo-a7bb963c619741bbc4e00331c93fb50f60f1faef.tar.gz
gentoo-a7bb963c619741bbc4e00331c93fb50f60f1faef.tar.bz2
gentoo-a7bb963c619741bbc4e00331c93fb50f60f1faef.zip
dev-libs/libfmt: Small, safe and fast formatting library
Bug: https://bugs.gentoo.org/show_bug.cgi?id=611804 Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4143
Diffstat (limited to 'dev-libs/libfmt/libfmt-9999.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
new file mode 100644
index 000000000000..aa04d6331efe
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="BSD-2"
+IUSE="test"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}