summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-18 15:24:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-20 13:30:10 +0200
commitc4593a0f32b0d59f85833491f7b215fcbc097837 (patch)
tree9d4b8d977a1a38db56cb9748472b4f578909863b /dev-libs/kopeninghours
parentapp-office/merkuro: 24.04.90 version bump (diff)
downloadgentoo-c4593a0f32b0d59f85833491f7b215fcbc097837.tar.gz
gentoo-c4593a0f32b0d59f85833491f7b215fcbc097837.tar.bz2
gentoo-c4593a0f32b0d59f85833491f7b215fcbc097837.zip
dev-libs/kopeninghours: 24.04.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-24.04.90.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 32e382728b50..16039755715e 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1,2 +1,3 @@
DIST kopeninghours-23.08.5.tar.xz 72568 BLAKE2B 84e418d95f4a7261786a101882000bed0ca721931cc419e0330edb0f659e38459063d49c75ca643d169e9326ed66694130cfeebef51183c89e02efd02f6f3133 SHA512 a95cd3c446699d8bd95f2f746cb8b4187c7d2027067e5c731afe371a3313a5569780110e8acbf52d125da673aff4b2567da9f2b8c07a4412cf1d7540baad7a14
DIST kopeninghours-24.02.2.tar.xz 73660 BLAKE2B 779ea9c966c7223e80bb88120d6cfc581597d5b27c1e716fd30d21815814dfd406ae2c904c772a4ef0e97b1f951c1e82a4572d4c0ce995d6f79c75905a7eca07 SHA512 1540dc045e65c9751c5571b3e2c170f03474282c8e342c41af3101034bdddc8af9e9de17b63b0f3515672b0fcb8a821f5a5acfa074814639f3957aed9e53d857
+DIST kopeninghours-24.04.90.tar.xz 74628 BLAKE2B 10c63666fe28a240cd7c78d11049e621c7e133549d5e98f9e3e8411ea6bad9b9f543fcae75c096a96dddf85ac7367aa4edffcc28cc614f64c8c44f719d063d50 SHA512 e513e39171975d82bdf5b2196cac9018897c806971bb1a49eaa19a13daf47d187241da4559546bd7edd888e4c1cc413bee96ad58dea0e819959827bfdff6ee93
diff --git a/dev-libs/kopeninghours/kopeninghours-24.04.90.ebuild b/dev-libs/kopeninghours/kopeninghours-24.04.90.ebuild
new file mode 100644
index 000000000000..796172457765
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-24.04.90.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kholidays-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}