summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-12-09 21:15:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-12-09 21:54:32 +0100
commit3503e0bc9a013a21524835d8a43a06e5faaf459e (patch)
treecf9aa0d7ac342309ffade751326a91114224b090 /dev-libs/kopeninghours
parentapp-office/kalendar: 22.12.0 version bump (diff)
downloadgentoo-3503e0bc9a013a21524835d8a43a06e5faaf459e.tar.gz
gentoo-3503e0bc9a013a21524835d8a43a06e5faaf459e.tar.bz2
gentoo-3503e0bc9a013a21524835d8a43a06e5faaf459e.zip
dev-libs/kopeninghours: 22.12.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-22.12.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 0621652f5dc7..4e11f4dd1edb 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-22.08.3.tar.xz 70540 BLAKE2B 76ac44a67b29133e0b499f0f11808f61e6c05b820eaaa7d0ef2656d1340e17b7663df1d4474f0735880f448c1fc0b6ee41cb86f3366afe458697edec8e269bbb SHA512 1874e61716f2e02e0df6e34e8ff451541e2e34649426ca610a5d7947df8f42dea1dc3067fb07221150fcb6dd3d942727e3e3c135a8ec76ed16ff1acd2ceebf6b
+DIST kopeninghours-22.12.0.tar.xz 71064 BLAKE2B 2440c0b318177cabfbf1f18706663194fe6d35b41398ddc49069e76087e6310a211b4f4bf72ed936e4e0f3f035347b3b4d133fe08576d44306a8a602fda2f3ed SHA512 661039b785920b0f5cd58c57c7a05989ca7d71f176c2fc2a6b6eaaa02f8fda5052fa1f80832746da3927dc770db28754b3852514f741efd38579621afd5d5c4f
diff --git a/dev-libs/kopeninghours/kopeninghours-22.12.0.ebuild b/dev-libs/kopeninghours/kopeninghours-22.12.0.ebuild
new file mode 100644
index 000000000000..d1d644e4ab8b
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-22.12.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.99.0
+QTMIN=5.15.5
+PYTHON_COMPAT=( python3_{8..11} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}