summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-07-27 11:15:16 +0300
committerMart Raudsepp <leio@gentoo.org>2019-07-27 11:35:54 +0300
commit56947fdae9af5c6fa1c3ba6e3d97882a299f96eb (patch)
treef32891a1fe030e616612557f4fc8ee5e08c2cbed /dev-libs/jsonrpc-glib/jsonrpc-glib-3.32.0.ebuild
parentdev-util/sysprof: bump to 3.32.0 (diff)
downloadgentoo-56947fdae9af5c6fa1c3ba6e3d97882a299f96eb.tar.gz
gentoo-56947fdae9af5c6fa1c3ba6e3d97882a299f96eb.tar.bz2
gentoo-56947fdae9af5c6fa1c3ba6e3d97882a299f96eb.zip
dev-libs/jsonrpc-glib: bump to 3.32.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/jsonrpc-glib/jsonrpc-glib-3.32.0.ebuild')
-rw-r--r--dev-libs/jsonrpc-glib/jsonrpc-glib-3.32.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/jsonrpc-glib/jsonrpc-glib-3.32.0.ebuild b/dev-libs/jsonrpc-glib/jsonrpc-glib-3.32.0.ebuild
new file mode 100644
index 000000000000..b1e135ac476c
--- /dev/null
+++ b/dev-libs/jsonrpc-glib/jsonrpc-glib-3.32.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala
+
+DESCRIPTION="JSON-RPC library for GLib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk-doc +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib[introspection?]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_profiling=false # -pg passing
+ $(meson_use introspection with_introspection)
+ $(meson_use vala with_vapi)
+ $(meson_use gtk-doc enable_gtk_doc)
+ $(meson_use test enable_tests)
+ )
+ meson_src_configure
+}