summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-05-25 01:34:50 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-25 01:35:18 +0200
commitcef7d40269fb9aa6c53fec9038ac839639b0d8e5 (patch)
tree4ac79b01235f01c70b5f7247f7613d7e980619c0 /dev-libs/intel-compute-runtime
parentdev-util/intel-graphics-compiler: add 1.0.16695.4 (diff)
downloadgentoo-cef7d40269fb9aa6c53fec9038ac839639b0d8e5.tar.gz
gentoo-cef7d40269fb9aa6c53fec9038ac839639b0d8e5.tar.bz2
gentoo-cef7d40269fb9aa6c53fec9038ac839639b0d8e5.zip
dev-libs/intel-compute-runtime: add 24.17.29377.6
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-24.17.29377.6.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index cfb233924054..ff3374bc3730 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1 +1,2 @@
DIST intel-compute-runtime-24.13.29138.7.tar.gz 7056376 BLAKE2B e09c0a8e4b3f31b53879430401074f9861dc9384524dfe6c2bd87c9f12cd064688b08da1eefc7f9453141b008181bb66f187e4bf8f1fe0db8df4946b3cca6313 SHA512 01b3ded0d42c439314f83e9eac45dcdaaa401128fa83836d2cee4514351b8b43ae0b19a6485a16f5f08ef0d76595e6ee749fe1fff9a5ee04677e3d5ef33408da
+DIST intel-compute-runtime-24.17.29377.6.tar.gz 7038804 BLAKE2B feb09b6627b5dbd376a88705fca61514e5f60aa2014617a591451f0be493dedc87e228f8599fd2e2488623fcc827d831f4294fa4b34375a75e17438b76d4fd97 SHA512 9cda876ebdff1a17cb495f95b637c8aac82dc58433da67d1f312b74dd423ca9f536dcbd10454f1e0702e3181b4f5d4eeb2d31d6d99a756749321b128cf1e9cc2
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-24.17.29377.6.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.17.29377.6.ebuild
new file mode 100644
index 000000000000..717beccf91d2
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.17.29377.6.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ >=dev-util/intel-graphics-compiler-1.0.15985.15
+ >=media-libs/gmmlib-22.3.17:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/intel-metrics-discovery:=
+ dev-libs/intel-metrics-library:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-system-controller-0.8.16:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.16.1:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ media-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch"
+)
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-lto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}