summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-08-26 01:52:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-08-26 01:53:49 +0200
commitaa757b42a7d39657a468853756a7b4ca74a76ced (patch)
tree7faa57da15e0f010ab4922b0da45ef01c2d8649b /dev-libs/intel-compute-runtime
parentnet-analyzer/sngrep: fix LICENSE (diff)
downloadgentoo-aa757b42a7d39657a468853756a7b4ca74a76ced.tar.gz
gentoo-aa757b42a7d39657a468853756a7b4ca74a76ced.tar.bz2
gentoo-aa757b42a7d39657a468853756a7b4ca74a76ced.zip
dev-libs/intel-compute-runtime: add 24.31.30508.7
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-24.31.30508.7.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 179814b4987e..f0c3ced84d0a 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1 +1,2 @@
DIST intel-compute-runtime-24.22.29735.21.tar.gz 7083856 BLAKE2B dbb31259b3a4305e42d4dce685ce3f98b3b308451d2b1061c6fcba5cc2b2aaf6862eaa326619f8b073478c64fc45994adc261583c0070464b027fda46028afa5 SHA512 64cbfdab69c595c118e37526be744bad95cf11e1c9de34aaec308cead5346d802e98e67f155da03fd174e51e7f78a38b3b6f48ba6e004f3181b533c8d31e851e
+DIST intel-compute-runtime-24.31.30508.7.tar.gz 7323254 BLAKE2B 2fbd1e52e7c25b1180aba7ddc0ebc0aadeb20c78c464ad72c5e9cd88799e181db979ac55bea215390d968d7eb128d9f96a71acebed3430916e318d3c55fbbae2 SHA512 31e35f82a16f3e6961afa12ae5307617cc4114a04a27260caa86d9eff5683df6171df6d3efc83b0a94f3bd80417cc0a2b6a0085d761aa58242d0fd018e35c4a9
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-24.31.30508.7.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.31.30508.7.ebuild
new file mode 100644
index 000000000000..f52e95b87bac
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.31.30508.7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ >=dev-util/intel-graphics-compiler-1.0.17537.1
+ >=media-libs/gmmlib-22.3.19:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/intel-metrics-discovery:=
+ dev-libs/intel-metrics-library:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-system-controller-0.8.16:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.17.28:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ media-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Filtered for two reasons:
+ # 1) https://github.com/intel/compute-runtime/issues/528
+ # 2) bug #930199
+ filter-lto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO_DISABLE_LTO="ON"
+ -DNEO_DISABLE_LD_GOLD="ON"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}