summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-13 03:09:29 +0100
committerSam James <sam@gentoo.org>2022-10-13 03:09:29 +0100
commitc62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1 (patch)
tree8e284b2d5ae4275a6b72b3361df7e2897b9b5e4f /dev-libs/http-fetcher
parentwww-client/elinks: add 0.15.1 (diff)
downloadgentoo-c62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1.tar.gz
gentoo-c62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1.tar.bz2
gentoo-c62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1.zip
dev-libs/http-fetcher: fix underquoted http-fetcher.m4 macro again
Bug: https://bugs.gentoo.org/299940 Closes: https://bugs.gentoo.org/876911 Fixes: 9c3bfee419467b417400fe45921205b502e17d68 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/http-fetcher')
-rw-r--r--dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch13
-rw-r--r--dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild (renamed from dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild)11
2 files changed, 20 insertions, 4 deletions
diff --git a/dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch b/dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch
new file mode 100644
index 000000000000..2135de07851e
--- /dev/null
+++ b/dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/876911
+https://bugs.gentoo.org/299940
+--- a/http-fetcher.m4
++++ b/http-fetcher.m4
+@@ -10,7 +10,7 @@ dnl understanding is that this should only be done if necessary.
+ dnl The macro also adds the appropriate -L and -I values to CFLAGS so that
+ dnl headers are found and libraries are linked.
+ dnl
+-AC_DEFUN(AC_PATH_HFETCHER,
++AC_DEFUN([AC_PATH_HFETCHER],
+ [dnl
+
+ darwin=no;
diff --git a/dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
index 0d694ccc9dd4..97ad5484327a 100644
--- a/dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild
+++ b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -10,14 +10,18 @@ MY_P="${P/-/_}"
DESCRIPTION="Library for downloading files via HTTP using the GET method"
HOMEPAGE="http://http-fetcher.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86"
IUSE="debug"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-underquoted-http-fetcher-macro.patch
+)
+
src_prepare() {
default
eautoreconf
@@ -26,7 +30,6 @@ src_prepare() {
src_configure() {
econf \
--disable-strict \
- --disable-static \
$(use_enable debug)
}