summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-18 00:14:51 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-18 00:34:08 -0400
commitf6bdd8113833c50fc0d8c28e6a44812bb8bbad70 (patch)
tree3ff2a10b7558c51a9d0ceab312d01c8de76c5c85 /dev-libs/gobject-introspection-common
parentdev-libs/glib: Version bump to 2.74.0 (diff)
downloadgentoo-f6bdd8113833c50fc0d8c28e6a44812bb8bbad70.tar.gz
gentoo-f6bdd8113833c50fc0d8c28e6a44812bb8bbad70.tar.bz2
gentoo-f6bdd8113833c50fc0d8c28e6a44812bb8bbad70.zip
dev-libs/gobject-introspection-common: Version bump to 1.74.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gobject-introspection-common')
-rw-r--r--dev-libs/gobject-introspection-common/Manifest1
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.74.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/Manifest b/dev-libs/gobject-introspection-common/Manifest
index cb6ad8cd2b09..3df3cc05972b 100644
--- a/dev-libs/gobject-introspection-common/Manifest
+++ b/dev-libs/gobject-introspection-common/Manifest
@@ -1 +1,2 @@
DIST gobject-introspection-1.72.0.tar.xz 1040936 BLAKE2B fd7600a927e57d5a076c203a084afe56a738d3a93109055be7bee22a96d6d5b08892300260288e5b83f883e54ca658cb24ef5c862abe435820c963bbf0cf8496 SHA512 b8fba2bd12e93776c55228acf3487bef36ee40b1abdc7f681b827780ac94a8bfa1f59b0c30d60fa5a1fea2f610de78b9e52029f411128067808f17eb6374cdc5
+DIST gobject-introspection-1.74.0.tar.xz 1044008 BLAKE2B 223bb9b8b452f03945f941086e47fb3b14f03f8353f4f903b21e3f494af728652a44de986752374057e90dd8111f21f5b0cd3e00bb0a8c3aa25c8261bb0b9247 SHA512 decff5dda0ec5ec0afda4d6bcd3bdadcbf34289002c0d9c0c77ecf8c5d3f15d196b24d8035041545031006acbdfe76af47c42da061c40e200c87f2c74cd301f0
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.74.0.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.74.0.ebuild
new file mode 100644
index 000000000000..67c0ee1d1c8a
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.74.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}