summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-08 12:18:55 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-08 20:16:36 -0400
commit6dee395ba6adb811397e31cab0985aa4e47fd18c (patch)
tree1d7d4176e74571c7415dbdc9a3280753b0c21cce /dev-libs/gobject-introspection-common
parentpackage.mask: Mask glibc-2.36 (diff)
downloadgentoo-6dee395ba6adb811397e31cab0985aa4e47fd18c.tar.gz
gentoo-6dee395ba6adb811397e31cab0985aa4e47fd18c.tar.bz2
gentoo-6dee395ba6adb811397e31cab0985aa4e47fd18c.zip
dev-libs/gobject-introspection-common: Version bump to 1.78.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32689 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gobject-introspection-common')
-rw-r--r--dev-libs/gobject-introspection-common/Manifest1
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.78.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/Manifest b/dev-libs/gobject-introspection-common/Manifest
index 2d9f357291f1..aeb50dcc6068 100644
--- a/dev-libs/gobject-introspection-common/Manifest
+++ b/dev-libs/gobject-introspection-common/Manifest
@@ -1 +1,2 @@
DIST gobject-introspection-1.76.1.tar.xz 1055416 BLAKE2B 2251c34b543c95f95bdec6853c8234db1b2e6271e729eaa5abf28e39c7718b326e0813a1214c62fb4634fd11218c4c856e6651de09081b01c9fcf8f73b8cf316 SHA512 84331a30f8854d2259609650c21aadd6363ea1417a75828bd395f8f4346da1c6d6550cff5f2c9f5f6fd6fbf2a9d27b5880c2ee1616fa905c5f362384d481a916
+DIST gobject-introspection-1.78.0.tar.xz 1060136 BLAKE2B ae95ad5cec48f0eb001e1ba65cd6e88ab8846d1ab6721ac421f6077f1a69fca1989a0631a7c852361d4b92f7f25503e3f505e734055d3f61530f829924f37972 SHA512 b7749295437255d45f5f842195315105d7b85bddb20bf205c7bd7f0c9e9e77fe1db2c84af6d784b54fb0d8eef488895f5eb9439ccf4ca81d03e802802b13e5dd
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.78.0.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.78.0.ebuild
new file mode 100644
index 000000000000..8918bd9672fe
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.78.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}