summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Denisov <pavel.a.denisov@gmail.com>2017-12-26 17:41:05 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-08 17:35:37 +0100
commit37f82da08418033a5a3c6240ae41326f7d8937f8 (patch)
treeb73e43c05170c0e8a26e8aa1f760a4c600d5989a /dev-libs/cudnn
parentdev-util/vint: add Python 3.6 support (diff)
downloadgentoo-37f82da08418033a5a3c6240ae41326f7d8937f8.tar.gz
gentoo-37f82da08418033a5a3c6240ae41326f7d8937f8.tar.bz2
gentoo-37f82da08418033a5a3c6240ae41326f7d8937f8.zip
dev-libs/cudnn: version bump.
Closes: https://bugs.gentoo.org/641616 Closes: https://github.com/gentoo/gentoo/pull/6645 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/cudnn')
-rw-r--r--dev-libs/cudnn/Manifest1
-rw-r--r--dev-libs/cudnn/cudnn-7.0.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/cudnn/Manifest b/dev-libs/cudnn/Manifest
index 94f12de3d363..a6d00b4c87e1 100644
--- a/dev-libs/cudnn/Manifest
+++ b/dev-libs/cudnn/Manifest
@@ -1 +1,2 @@
DIST cudnn-8.0-linux-x64-v6.0.tgz 201134139 BLAKE2B a7e616c671272a3a0f0c51b93646c8c60302c3dec85b71144e011bc3460d0ce80ff75d39869c05c4ef183d2d09aff31bb470a3fd3fd3d79b581a7a2d5a349279 SHA512 ddeeacb5b449920d942a26b98c353d78fd6f7d7fb3b3ce42a078626473efdda25c7ae641232702d62eb5749e39ecfd03e88346119c920c19348ac3ee82d3ff47
+DIST cudnn-9.0-linux-x64-v7.tgz 348817823 BLAKE2B 5ac2d5c6794f18e2f9de7b43d81f196391e193bc795ca89a5810a7e6f77d3f241c5f61b16a54294bedf0ee08d48c88ccfb85b552f4be76a8bb42bb76f8382d7b SHA512 63752fe8991b750794bd41d720d1ab2c94584fd9a0e297c68549d8e44cf2742f0601021ae54f5227e4865869fddb5d5b2f7445bfda2c0808b8973345337a907e
diff --git a/dev-libs/cudnn/cudnn-7.0.5.ebuild b/dev-libs/cudnn/cudnn-7.0.5.ebuild
new file mode 100644
index 000000000000..e63b0750db22
--- /dev/null
+++ b/dev-libs/cudnn/cudnn-7.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CUDA_PV=9.0
+
+inherit versionator
+
+DESCRIPTION="NVIDIA Accelerated Deep Learning on GPU library"
+HOMEPAGE="https://developer.nvidia.com/cuDNN"
+
+MY_PV_MAJOR=$(get_major_version)
+SRC_URI="cudnn-${CUDA_PV}-linux-x64-v${MY_PV_MAJOR}.tgz"
+
+SLOT="0/7"
+KEYWORDS="~amd64 ~amd64-linux"
+RESTRICT="fetch"
+LICENSE="NVIDIA-cuDNN"
+
+S="${WORKDIR}"
+
+DEPENDS="=dev-util/nvidia-cuda-toolkit-${CUDA_PV}*"
+RDEPENDS="${DEPENDS}"
+
+src_install() {
+ insinto /opt
+ doins -r *
+}