summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2023-02-07 21:10:56 -0500
committerArthur Zamarin <arthurzam@gentoo.org>2023-02-09 17:13:34 +0200
commitf71faa99a9c06babb9def382a9fa2d4a08149f15 (patch)
tree9f314bf88b10918273be911cc946b5dc4267bf01 /dev-libs/crc32c
parentdev-qt/qtsql: Stabilize 5.15.8-r1 arm, #893652 (diff)
downloadgentoo-f71faa99a9c06babb9def382a9fa2d4a08149f15.tar.gz
gentoo-f71faa99a9c06babb9def382a9fa2d4a08149f15.tar.bz2
gentoo-f71faa99a9c06babb9def382a9fa2d4a08149f15.zip
dev-libs/crc32c: fix building against dev-cpp/gtest-1.13.0
Closes: https://bugs.gentoo.org/893346 Closes: https://github.com/gentoo/gentoo/pull/29475 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-libs/crc32c')
-rw-r--r--dev-libs/crc32c/crc32c-1.1.2-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/crc32c/crc32c-1.1.2-r2.ebuild b/dev-libs/crc32c/crc32c-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..3eddf42a6270
--- /dev/null
+++ b/dev-libs/crc32c/crc32c-1.1.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="CRC32C implementation with support for CPU-specific acceleration instructions"
+HOMEPAGE="https://github.com/google/crc32c"
+SRC_URI="https://github.com/google/crc32c/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-cpp/gtest )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.1-system-testdeps.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ sed -e '/-Werror/d' \
+ -e '/-march=armv8/d' \
+ -i CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=14 # C++14 or later required for >=gtest-1.13.0
+ -DCRC32C_BUILD_TESTS=$(usex test)
+ -DCRC32C_BUILD_BENCHMARKS=OFF
+ -DCRC32C_USE_GLOG=OFF
+ )
+
+ cmake_src_configure
+}