summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-09-02 11:56:21 +0000
committerSam James <sam@gentoo.org>2020-09-09 01:03:05 +0000
commitee737802161977c18f56ba89096c344d3bba5da2 (patch)
treeed9a339f53f6f343ab200270d2280c07f2560fd9 /dev-libs/boxfort
parentdev-util/cram: add python3.9 support (diff)
downloadgentoo-ee737802161977c18f56ba89096c344d3bba5da2.tar.gz
gentoo-ee737802161977c18f56ba89096c344d3bba5da2.tar.bz2
gentoo-ee737802161977c18f56ba89096c344d3bba5da2.zip
dev-libs/boxfort: add python3.{8,9} support
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17385 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/boxfort')
-rw-r--r--dev-libs/boxfort/Manifest1
-rw-r--r--dev-libs/boxfort/boxfort-0.0.1_pre20200902.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/boxfort/Manifest b/dev-libs/boxfort/Manifest
index 3bc02199164c..a8d3b99e0936 100644
--- a/dev-libs/boxfort/Manifest
+++ b/dev-libs/boxfort/Manifest
@@ -1 +1,2 @@
+DIST boxfort-0.0.1_pre20200902.tar.gz 41643 BLAKE2B 6ac53b632f604ffd6b790a026703a2d64da65fc03cc71ebc3e4da3463e7c5a44ec99e85e3cdac8e5756afaf7d98785955815e194929bbc8dd6b6fd90bfb3fd52 SHA512 96090372f3e546f53f82c515c3f9e557fdd67eb7bc735683b30d8a66c2536cf21261b0467e449ccbd13e914b7cf4ea3da1a37c4108b215d6d0d08cdb68944b1e
DIST boxfort-1456d9a3a3bcb506cdcd1b5d4b852e967deb5e57.tar.gz 41705 BLAKE2B 89644ecf64e5a5df718fa4f873d21e281c777c893af5a8f71c8a1913270ca6c67dc36113e5d219540bb04c7f9e26be22f7e778bd9bdce230df8c0edf3a707612 SHA512 249b0bd0048c53c74d2b50f1b7caf84b0ac0823679bb6adaade095a2ff26586f14f58cee960610d99dbc38c8196cbdb99143815b14d10b7f13a12f96d309e302
diff --git a/dev-libs/boxfort/boxfort-0.0.1_pre20200902.ebuild b/dev-libs/boxfort/boxfort-0.0.1_pre20200902.ebuild
new file mode 100644
index 000000000000..970c74b5d5f0
--- /dev/null
+++ b/dev-libs/boxfort/boxfort-0.0.1_pre20200902.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit meson python-any-r1
+
+BOXFORT_COMMIT="ac0507b3f45fe58100b528baeb8ca04270b4a8ff"
+
+DESCRIPTION="Convenient & cross-platform sandboxing C library"
+HOMEPAGE="https://github.com/Snaipe/BoxFort"
+SRC_URI="https://github.com/Snaipe/BoxFort/archive/${BOXFORT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ $(python_gen_any_dep 'dev-util/cram[${PYTHON_USEDEP}]')
+ )"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/BoxFort-${BOXFORT_COMMIT}"
+
+python_check_deps() {
+ use test && has_version "dev-util/cram[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dsamples=$(usex test true false)
+ -Dtests=$(usex test true false)
+ )
+
+ meson_src_configure
+}