summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-12 10:17:01 +0100
committerSam James <sam@gentoo.org>2023-04-12 10:17:36 +0100
commit17490756752b15d2ee590ac1a6a9c6e170b3cde1 (patch)
tree1c768b778301b2e667951c6979c56c046da047a0 /dev-libs/botan
parentsci-libs/tokenizers: add dep on setuptools_rust (diff)
downloadgentoo-17490756752b15d2ee590ac1a6a9c6e170b3cde1.tar.gz
gentoo-17490756752b15d2ee590ac1a6a9c6e170b3cde1.tar.bz2
gentoo-17490756752b15d2ee590ac1a6a9c6e170b3cde1.zip
dev-libs/botan: fix USE=python for 3.0.0
Closes: https://bugs.gentoo.org/904219 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/botan-2.19.3.ebuild5
-rw-r--r--dev-libs/botan/botan-3.0.0.ebuild2
2 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/botan/botan-2.19.3.ebuild b/dev-libs/botan/botan-2.19.3.ebuild
index 10d64d9a5ec0..1ad66cddebfd 100644
--- a/dev-libs/botan/botan-2.19.3.ebuild
+++ b/dev-libs/botan/botan-2.19.3.ebuild
@@ -15,7 +15,8 @@ SRC_URI+=" verify-sig? ( https://botan.randombit.net/releases/${MY_P}.tar.xz.asc
S="${WORKDIR}/${MY_P}"
LICENSE="BSD-2"
-SLOT="2/$(ver_cut 1-2)" # soname version
+# New major versions are parallel-installable
+SLOT="$(ver_cut 1)/$(ver_cut 1-2)" # soname version
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86 ~ppc-macos"
IUSE="doc boost bzip2 lzma python static-libs sqlite test tools zlib"
RESTRICT="!test? ( test )"
@@ -175,6 +176,6 @@ src_install() {
# Manually install the Python bindings (bug #723096)
if use python ; then
- python_foreach_impl python_domodule src/python/botan2.py
+ python_foreach_impl python_domodule src/python/botan$(ver_cut 1).py
fi
}
diff --git a/dev-libs/botan/botan-3.0.0.ebuild b/dev-libs/botan/botan-3.0.0.ebuild
index 79bf305f90f5..e31d7d9348d4 100644
--- a/dev-libs/botan/botan-3.0.0.ebuild
+++ b/dev-libs/botan/botan-3.0.0.ebuild
@@ -176,6 +176,6 @@ src_install() {
# Manually install the Python bindings (bug #723096)
if use python ; then
- python_foreach_impl python_domodule src/python/botan2.py
+ python_foreach_impl python_domodule src/python/botan$(ver_cut 1).py
fi
}