summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-01-26 13:19:57 +0100
committerDavid Seifert <soap@gentoo.org>2024-01-26 13:19:57 +0100
commitc422e8f408e2091948d2d34080c6f7ac5d32e359 (patch)
tree536eccadec7906aaf97775d5790da0d9b90c6abc /dev-libs/boost
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-c422e8f408e2091948d2d34080c6f7ac5d32e359.tar.gz
gentoo-c422e8f408e2091948d2d34080c6f7ac5d32e359.tar.bz2
gentoo-c422e8f408e2091948d2d34080c6f7ac5d32e359.zip
dev-libs/boost: drop boost.mpi __init__.py
* Upstream is unresponsive and the file still uses pre-PEP328 imports, instead let the python interpreter load `mpi.so` directly. Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.84.0-r3.ebuild (renamed from dev-libs/boost/boost-1.84.0-r2.ebuild)27
1 files changed, 8 insertions, 19 deletions
diff --git a/dev-libs/boost/boost-1.84.0-r2.ebuild b/dev-libs/boost/boost-1.84.0-r3.ebuild
index 8240ff805fc4..a9b31a9a58c3 100644
--- a/dev-libs/boost/boost-1.84.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.84.0-r3.ebuild
@@ -34,10 +34,10 @@ RESTRICT="test"
RDEPEND="
bzip2? ( app-arch/bzip2:=[${MULTILIB_USEDEP}] )
- icu? ( >=dev-libs/icu-3.6:=[${MULTILIB_USEDEP}] )
+ icu? ( dev-libs/icu:=[${MULTILIB_USEDEP}] )
!icu? ( virtual/libiconv[${MULTILIB_USEDEP}] )
lzma? ( app-arch/xz-utils:=[${MULTILIB_USEDEP}] )
- mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP},cxx,threads] )
+ mpi? ( virtual/mpi[${MULTILIB_USEDEP},cxx,threads] )
python? (
${PYTHON_DEPS}
numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
@@ -50,24 +50,14 @@ BDEPEND=">=dev-build/b2-4.9.2"
PATCHES=(
"${FILESDIR}"/${PN}-1.81.0-disable_icu_rpath.patch
"${FILESDIR}"/${PN}-1.79.0-build-auto_index-tool.patch
- # Boost.MPI's __init__.py doesn't work on Py3
- "${FILESDIR}"/${PN}-1.79.0-boost-mpi-python-PEP-328.patch
- "${FILESDIR}"/${PN}-1.83.0-math-gcc14.patch
# upstreamed
+ "${FILESDIR}"/${PN}-1.83.0-math-gcc14.patch
"${FILESDIR}"/${PN}-1.79.0-context-x32.patch
"${FILESDIR}"/${PN}-1.84.0-signals2-patch1.patch
"${FILESDIR}"/${PN}-1.84.0-signals2-patch2.patch
)
-python_bindings_needed() {
- multilib_is_native_abi && use python
-}
-
-tools_needed() {
- multilib_is_native_abi && use tools
-}
-
create_user-config.jam() {
local user_config_jam="${BUILD_DIR}"/user-config.jam
if [[ -s ${user_config_jam} ]]; then
@@ -90,7 +80,7 @@ create_user-config.jam() {
${mpi_configuration}
__EOF__
- if python_bindings_needed; then
+ if multilib_native_use python; then
append_to_user_config() {
local py_config
if tc-is-cross-compiler; then
@@ -103,7 +93,7 @@ create_user-config.jam() {
python_foreach_impl append_to_user_config
fi
- if python_bindings_needed && use numpy; then
+ if multilib_native_use python && use numpy; then
einfo "Enabling support for NumPy extensions in Boost.Python"
else
einfo "Disabling support for NumPy extensions in Boost.Python"
@@ -138,7 +128,7 @@ ejam() {
create_user-config.jam
local b2_opts=( "--user-config=${BUILD_DIR}/user-config.jam" )
- if python_bindings_needed; then
+ if multilib_native_use python; then
append_to_b2_opts() {
b2_opts+=( python="${EPYTHON#python}" )
}
@@ -212,7 +202,7 @@ multilib_src_compile() {
--prefix="${EPREFIX}"/usr \
"${OPTIONS[@]}" || die
- if tools_needed; then
+ if multilib_native_use tools; then
pushd tools >/dev/null || die
ejam \
--prefix="${EPREFIX}"/usr \
@@ -229,7 +219,7 @@ multilib_src_install() {
--libdir="${ED}"/usr/$(get_libdir) \
"${OPTIONS[@]}" install || die "Installation of Boost libraries failed"
- if tools_needed; then
+ if multilib_native_use tools; then
dobin dist/bin/*
insinto /usr/share
@@ -286,7 +276,6 @@ multilib_src_install_all() {
if use mpi; then
move_mpi_py_into_sitedir() {
python_moduleinto boost
- python_domodule "${S}"/libs/mpi/build/__init__.py
python_domodule "${ED}"/usr/$(get_libdir)/boost-${EPYTHON}/mpi.so
rm -r "${ED}"/usr/$(get_libdir)/boost-${EPYTHON} || die