summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2020-12-10 09:03:38 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-13 12:50:21 +0200
commitfdb1dfcb4ca5cbafb4a2ca09b7491cce6dbcde66 (patch)
tree0899ea3b308c72603a4f6d619c285d809dfd287c /dev-libs/aws-sdk-cpp
parentdev-libs/aws-c-event-stream: remove obsolete ebuild (diff)
downloadgentoo-fdb1dfcb4ca5cbafb4a2ca09b7491cce6dbcde66.tar.gz
gentoo-fdb1dfcb4ca5cbafb4a2ca09b7491cce6dbcde66.tar.bz2
gentoo-fdb1dfcb4ca5cbafb4a2ca09b7491cce6dbcde66.zip
dev-libs/aws-sdk-cpp: Version 1.8.105 bump
The following new modules have been added: * Amazon ECR Public * Amazon EMR on EKS * Amazon Lookout for Vision * Amazon Managed Workflows for Apache Airflow (Amazon MWAA) * Amazon Timestream * Audit Manager * Detective * DevOps Guru The following modules are now enabled in various categories: * connect-contact-lens * customer-profiles * databrew * healthlake * network-firewall * s3outposts * sagemaker-edge * sagemaker-featurestore-runtime * sso-admin * servicecatalog-appregistry Further more the SDK now uses the new packages * dev-libs/aws-c-cal * dev-libs/aws-c-io and * dev-libs/s2n which have code for IO/TLS/SSL and a cryptography layer split out. In the wake of this bump, the mentioned new packages have been added, and the following packages bumped: * dev-libs/aws-c-common * dev-libs/aws-checksums * dev-libs/aws-c-event-stream All packages that suffer from the cmake-3.9.0/1 regression [0] have been updated to no longer accept dev-util/cmake-3.9.0 and dev-util/cmake-3.9.1 for building. Bug: https://bugs.gentoo.org/755932 Bug: https://bugs.gentoo.org/756325 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> [0] https://gitlab.kitware.com/cmake/cmake/-/issues/21529 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/aws-sdk-cpp')
-rw-r--r--dev-libs/aws-sdk-cpp/Manifest1
-rw-r--r--dev-libs/aws-sdk-cpp/aws-sdk-cpp-1.8.105.ebuild196
-rw-r--r--dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.105-remove_Werror_from_FLAGS.patch30
-rw-r--r--dev-libs/aws-sdk-cpp/metadata.xml43
4 files changed, 260 insertions, 10 deletions
diff --git a/dev-libs/aws-sdk-cpp/Manifest b/dev-libs/aws-sdk-cpp/Manifest
index c27b05abb983..787351bbd422 100644
--- a/dev-libs/aws-sdk-cpp/Manifest
+++ b/dev-libs/aws-sdk-cpp/Manifest
@@ -1 +1,2 @@
+DIST aws-sdk-cpp-1.8.105.tar.gz 31880249 BLAKE2B 1a2eb972b716c656f45b8d1d12fc3e7280c171e4a19eb5431e320511365d305211e8567aa7fcc3e21f553ad5befda91829df6ccf60c23296d210d0c7347bb2a2 SHA512 a76da095718c8569c62597431d29a0a54c1a7f81c1825894f0f40b1a971a3e0b4f0813da4ac929612b9bb5f92501ee6a034436faa6eef678d936117765baab7e
DIST aws-sdk-cpp-1.8.46.tar.gz 28989406 BLAKE2B 47a72d1e0578ecd28e376f3c6688a997faeeae41ba5e4ab5aeff59a2d8f592fc63746445728ab3236952cfc045dc683c816c77dfb8fbe3d98904e50013201ace SHA512 9fedc9de84721189f001a0a5fb2dd63987a366a37ec6354234b244da39929b420e6289bd319d0f056fa4274b7bc682d1aab2dddd5dc823abdf24b69536610ed4
diff --git a/dev-libs/aws-sdk-cpp/aws-sdk-cpp-1.8.105.ebuild b/dev-libs/aws-sdk-cpp/aws-sdk-cpp-1.8.105.ebuild
new file mode 100644
index 000000000000..55d368d0d705
--- /dev/null
+++ b/dev-libs/aws-sdk-cpp/aws-sdk-cpp-1.8.105.ebuild
@@ -0,0 +1,196 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="AWS SDK for C++"
+HOMEPAGE="https://aws.amazon.com/sdk-for-cpp/"
+SRC_URI="https://github.com/aws/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULES=(
+ access-management apigateway appconfig backup batch budgets chime cloud-desktop cloud-dev cloud-media
+ cloud-mobile cloudformation cloudfront cloudhsm cloudsearch cloudwatch cognito config dlm ebs ec2 ecr ecs
+ eks elasticache elasticbeanstalk elastic-inference elasticloadbalancing elasticmapreduce email es events
+ forecast frauddetector fsx globalaccelerator iot kendra kinesis kms lambda lex license-manager lightsail
+ lookoutvision machinelearning macie managedblockchain marketplace mwaa networkmanager opsworks
+ organizations other outposts personalize polly qldb queues rds rekognition resource-groups route53 s3
+ sagemaker secretsmanager securityhub serverlessrepo shield sns sqs textract timestream transcribe
+ translate waf
+)
+
+IUSE="+http libressl pulseaudio +rtti +ssl static-libs test unity-build ${MODULES[*]}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ http? ( net-misc/curl:= )
+ pulseaudio? ( media-sound/pulseaudio )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ >=dev-libs/aws-c-common-0.4.62:=[static-libs=]
+ >=dev-libs/aws-c-event-stream-0.2.5:=[static-libs=]
+ >=dev-libs/aws-checksums-0.1.10:=[static-libs=]
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-upgrade_android-build_build_and_test_android_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_binary-release-pipeline_lambda_publish_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_CI_ConstructReleaseDoc_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_CI_ExtractBuildArgs_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_CI_handle_release_notification_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_CI_move_release_doc_to_models_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_doc_crosslinks_generate_cross_link_data_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_build_3rdparty_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_build_example_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_dummy_web_server_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_endpoints_checker_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_gather_3rdparty_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_generate_sdks_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_renew_license_py-3.9.patch
+ "${FILESDIR}"/${PN}-upgrade_scripts_run_integration_tests_py-3.9.patch
+ "${FILESDIR}"/${P}-remove_Werror_from_FLAGS.patch
+)
+
+src_configure() {
+ local mybuildtargets="core"
+
+ for module in ${MODULES[@]}; do
+ if use ${module}; then
+ if [ "${module}" = "access-management" ] ; then
+ mybuildtargets+=";${module};accessanalyzer;acm;acm-pca;dataexchange;iam"
+ mybuildtargets+=";identity-management;identitystore;ram;sso;sso-admin;sso-oidc;sts"
+ elif [ "${module}" = "apigateway" ] ; then
+ mybuildtargets+=";${module};apigatewaymanagementapi;apigatewayv2"
+ elif [ "${module}" = "budgets" ] ; then
+ mybuildtargets+=";${module};ce;cur"
+ elif [ "${module}" = "cloud-desktop" ] ; then
+ mybuildtargets+=";appstream;workdocs;worklink;workmail;workmailmessageflow;workspaces"
+ elif [ "${module}" = "cloud-dev" ] ; then
+ mybuildtargets+=";cloud9;codeartifact;codebuild;codecommit;codedeploy;codeguruprofiler"
+ mybuildtargets+=";codeguru-reviewer;codepipeline;codestar;codestar-connections"
+ mybuildtargets+=";codestar-notifications;honeycode;xray"
+ if ! use "queues"; then
+ mybuildtargets+=";queues"
+ fi
+ elif [ "${module}" = "cloud-media" ] ; then
+ mybuildtargets+=";elastictranscoder;mediaconnect;mediaconvert;medialive;mediapackage"
+ mybuildtargets+=";mediapackage-vod;mediastore;mediastore-data;mediatailor"
+ elif [ "${module}" = "cloud-mobile" ] ; then
+ mybuildtargets+=";amplify;appsync;devicefarm;mobile;mobileanalytics;pinpoint"
+ mybuildtargets+=";pinpoint-email;sms-voice"
+ if ! use "sns"; then
+ mybuildtargets+=";sns"
+ fi
+ elif [ "${module}" = "cloudhsm" ] ; then
+ mybuildtargets+=";${module};cloudhsmv2"
+ elif [ "${module}" = "cloudsearch" ] ; then
+ mybuildtargets+=";${module};cloudsearchdomain"
+ elif [ "${module}" = "cloudwatch" ] ; then
+ mybuildtargets+=";application-insights;appmesh;auditmanager;cloudtrail;compute-optimizer"
+ mybuildtargets+=";detective;devops-guru;guardduty;health;inspector;logs;monitoring;synthetics"
+ elif [ "${module}" = "cognito" ] ; then
+ mybuildtargets+=";cognito-identity;cognito-idp;cognito-sync"
+ elif [ "${module}" = "dynamodb" ] ; then
+ mybuildtargets+=";${module};dax;dynamodbstreams"
+ elif [ "${module}" = "ec2" ] ; then
+ mybuildtargets+=";${module};autoscaling;autoscaling-plans;application-autoscaling"
+ mybuildtargets+=";ec2-instance-connect;elasticfilesystem;imagebuilder;savingsplans"
+ elif [ "${module}" = "ecr" ] ; then
+ mybuildtargets+=";${module};ecr-public"
+ elif [ "${module}" = "eks" ] ; then
+ mybuildtargets+=";${module};emr-containers"
+ elif [ "${module}" = "elasticloadbalancing" ] ; then
+ mybuildtargets+=";${module};elasticloadbalancingv2"
+ elif [ "${module}" = "email" ] ; then
+ mybuildtargets+=";${module};sesv2"
+ elif [ "${module}" = "events" ] ; then
+ mybuildtargets+=";${module};eventbridge"
+ elif [ "${module}" = "forecast" ] ; then
+ mybuildtargets+=";${module};forecastquery"
+ elif [ "${module}" = "iot" ] ; then
+ mybuildtargets+=";${module};greengrass;iot1click-devices;iot1click-projects"
+ mybuildtargets+=";iotanalytics;iot-data;iotevents;iotevents-data;iot-jobs-data"
+ mybuildtargets+=";iotsecuretunneling;iotsitewise;iotthingsgraph"
+ elif [ "${module}" = "kinesis" ] ; then
+ mybuildtargets+=";${module};firehose;ivs;kinesisanalytics;kinesisanalyticsv2"
+ mybuildtargets+=";kinesisvideo;kinesis-video-archived-media;kinesis-video-media"
+ mybuildtargets+=";kinesis-video-signaling"
+ elif [ "${module}" = "lex" ] ; then
+ mybuildtargets+=";${module};lex-models"
+ elif [ "${module}" = "macie" ] ; then
+ mybuildtargets+=";${module};macie2"
+ elif [ "${module}" = "marketplace" ] ; then
+ mybuildtargets+=";marketplacecommerceanalytics;marketplace-catalog"
+ mybuildtargets+=";marketplace-entitlement;meteringmarketplace;pricing"
+ mybuildtargets+=";servicecatalog-appregistry"
+ elif [ "${module}" = "opsworks" ] ; then
+ mybuildtargets+=";${module};opsworkscm"
+ elif [ "${module}" = "other" ] ; then
+ mybuildtargets+=";AWSMigrationHub;alexaforbusiness;appflow;braket;clouddirectory"
+ mybuildtargets+=";comprehend;comprehendmedical;connect;connect-contact-lens"
+ mybuildtargets+=";connectparticipant;customer-profiles;datapipeline;databrew;datasync"
+ mybuildtargets+=";directconnect;discovery;dms;docdb;ds;dynamodb;gamelift;glue"
+ mybuildtargets+=";groundstation;healthlake;importexport;kafka;lakeformation"
+ mybuildtargets+=";migrationhub-config;mq;mturk-requester;neptune;quicksight;redshift"
+ mybuildtargets+=";robomaker;sdb;schemas;service-quotas;servicecatalog;servicediscovery"
+ mybuildtargets+=";signer;sms;snowball;ssm;states;storagegateway;support;swf"
+ elif [ "${module}" = "outposts" ] ; then
+ mybuildtargets+=";${module};s3outposts"
+ elif [ "${module}" = "personalize" ] ; then
+ mybuildtargets+=";${module};personalize-events;personalize-runtime"
+ elif [ "${module}" = "polly" ] ; then
+ mybuildtargets+=";${module};text-to-speech"
+ elif [ "${module}" = "qldb" ] ; then
+ mybuildtargets+=";${module};qldb-session"
+ elif [ "${module}" = "rds" ] ; then
+ mybuildtargets+=";${module};pi;rds-data"
+ elif [ "${module}" = "resource-groups" ] ; then
+ mybuildtargets+=";${module};resourcegroupstaggingapi"
+ elif [ "${module}" = "route53" ] ; then
+ mybuildtargets+=";${module};route53domains;route53resolver"
+ elif [ "${module}" = "s3" ] ; then
+ mybuildtargets+=";${module};athena;awstransfer;glacier;s3-encryption;s3control;transfer"
+ elif [ "${module}" = "sagemaker" ] ; then
+ mybuildtargets+=";${module};sagemaker-a2i-runtime;sagemaker-edge"
+ mybuildtargets+=";sagemaker-featurestore-runtime;sagemaker-runtime"
+ elif [ "${module}" = "timestream" ] ; then
+ mybuildtargets+=";timestream-query;timestream-write"
+ elif [ "${module}" = "transcribe" ] ; then
+ mybuildtargets+=";${module};transcribestreaming"
+ elif [ "${module}" = "waf" ] ; then
+ mybuildtargets+=";${module};fms;network-firewall;waf-regional;wafv2"
+ else
+ mybuildtargets+=";${module}"
+ fi
+ fi
+ done
+
+ local mycmakeargs=(
+ -DAUTORUN_UNIT_TESTS=$(usex test)
+ -DBUILD_DEPS=NO
+ -DBUILD_ONLY="${mybuildtargets}"
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DCPP_STANDARD=17
+ -DENABLE_RTTI=$(usex rtti)
+ -DENABLE_TESTING=$(usex test)
+ -DENABLE_UNITY_BUILD=$(usex unity-build)
+ -DNO_ENCRYPTION=$(usex !ssl)
+ -DNO_HTTP_CLIENT=$(usex !http)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.105-remove_Werror_from_FLAGS.patch b/dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.105-remove_Werror_from_FLAGS.patch
new file mode 100644
index 000000000000..8130066cc391
--- /dev/null
+++ b/dev-libs/aws-sdk-cpp/files/aws-sdk-cpp-1.8.105-remove_Werror_from_FLAGS.patch
@@ -0,0 +1,30 @@
+--- a/cmake/compiler_settings.cmake 2020-12-12 15:31:17.703362345 +0100
++++ b/cmake/compiler_settings.cmake 2020-12-12 15:31:53.641363625 +0100
+@@ -53,7 +53,7 @@
+ endmacro()
+
+ macro(set_gcc_warnings)
+- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
++ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
+ if(COMPILER_CLANG)
+ if(PLATFORM_ANDROID)
+ # when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.
+--- a/cspell.json 2020-12-12 15:31:17.703362345 +0100
++++ b/cspell.json 2020-12-12 15:31:42.488363228 +0100
+@@ -13,7 +13,7 @@
+ // CMake
+ "cmake", "DCMAKE", "AUTORUN", "DEPS", "STREQUAL", "RPATH", "STREQUAL", "DTARGET", "TOOLCHAIN", "DANDROID", "DBUILD", "DGIT", "SYSROOT", "DSTATIC", "BINDIR", "LIBDIR", "INCLUDEDIR", "DHAS",
+ // Compiler and linker
+- "Wpedantic", "Wextra", "Werror", "xldscope", "Wtype", "Wunused", "RTTI", "ffunction", "fdata", "fsanitize", "pathconf", "unistd", "umask",
++ "Wpedantic", "Wextra", "xldscope", "Wtype", "Wunused", "RTTI", "ffunction", "fdata", "fsanitize", "pathconf", "unistd", "umask",
+ // Android NDK
+ "JNIEXPORT", "jint", "JNICALL", "jobject", "jclass", "jmethod", "Ljava",
+ // XML parser
+--- a/CI/install-test/CMakeLists.txt 2020-12-12 15:31:17.704362345 +0100
++++ b/CI/install-test/CMakeLists.txt 2020-12-12 15:32:06.433364080 +0100
+@@ -4,4 +4,4 @@
+ find_package(AWSSDK REQUIRED COMPONENTS s3)
+ add_executable(${PROJECT_NAME} "main.cpp")
+ target_link_libraries(${PROJECT_NAME} ${AWSSDK_LINK_LIBRARIES})
+-target_compile_options(${PROJECT_NAME} PRIVATE "-Wall" "-Werror")
++target_compile_options(${PROJECT_NAME} PRIVATE "-Wall")
diff --git a/dev-libs/aws-sdk-cpp/metadata.xml b/dev-libs/aws-sdk-cpp/metadata.xml
index 632e0dfe1944..1ddb8306031f 100644
--- a/dev-libs/aws-sdk-cpp/metadata.xml
+++ b/dev-libs/aws-sdk-cpp/metadata.xml
@@ -45,8 +45,8 @@
SSO : AWS Single Sign-On (SSO) makes it easy to centrally manage access to multiple AWS
accounts and business applications and provide users with single sign-on access to all
their assigned accounts and applications from one place.
- Also enables acm-pca, identity-management, identitystore, sso-oidc and sts (Security Token
- Service).
+ Also enables acm-pca, identity-management, identitystore, sso-admin, sso-oidc and sts
+ (Security Token Service).
</flag>
<flag name="apigateway">
Create and deploy your own REST and WebSocket APIs at any scale.
@@ -143,10 +143,16 @@
The following modules besides monitoring are also enabled:
Application Insights: Monitor .NET and SQL Server applications.
App Mesh : Monitor and control microservices running on AWS.
+ Audit Manager : Helps to continuously audit your AWS usage to simplify how you manage
+ risk and compliance with regulations and industry standards.
CloudTrail : Monitor AWS deployments in the cloud by getting a history of AWS API
calls, including API calls made via the AWS Management Console, the AWS SDKs, the
command line tools, and higher-level AWS services.
Compute Optimizer : Recommends optimal AWS compute resources for your workloads.
+ Detective : Analyze, investigate, and identify the root cause of security findings
+ or suspicious activities.
+ DevOps Guru : Generates operational insights using machine learning to help to improve
+ the performance of operational applications.
GuardDuty : Continuous security monitoring service.
Health : Provides personalized information about events that can affect the AWS
infrastructure, guides through scheduled changes, and accelerates the troubleshooting
@@ -194,6 +200,7 @@
</flag>
<flag name="ecr">
Amazon Elastic Container Registry (ECR) is a fully managed Docker container registry.
+ Also enables Amazon ECR Public.
</flag>
<flag name="ecs">
Amazon Elastic Container Service (ECS) is a highly scalable, fast, container management service.
@@ -201,6 +208,7 @@
<flag name="eks">
Amazon Elastic Kubernetes Service (EKS) is a managed service to run Kubernetes on AWS without
own Kubernetes clusters.
+ Also enables Amazon EMR on EKS.
</flag>
<flag name="elasticache">
Set up, manage, and scale distributed in-memory cache environments in the AWS Cloud
@@ -303,6 +311,10 @@
<flag name="lightsail">
The easiest way to get started with AWS for developers who just need virtual private servers
</flag>
+ <flag name="lookoutvision">
+ Amazon Lookout for Vision enables you to find visual defects in industrial products, accurately
+ and at scale.
+ </flag>
<flag name="machinelearning">
The algorithms of Amazon Machine Learning create machine learning (ML) models by finding
patterns in existing data. The service uses these models to process new data and generate
@@ -327,7 +339,11 @@
Marketplace Metering Service : A pricing and metering feature that AWS Marketplace sellers can
use to directly charge for their software along one of four dimensions: users, data,
bandwidth, or hosts.
- Also enables marketplace-catalog and pricing.
+ Also enables marketplace-catalog, pricing and servicecatalog-appregistry.
+ </flag>
+ <flag name="mwaa">
+ Amazon Managed Workflows for Apache Airflow (Amazon MWAA) is a managed service for Apache
+ Airflow that makes it easy for you to build and manage your workflows in the cloud.
</flag>
<flag name="networkmanager">
Transit Gateway Network Manager (Network Manager) enables you to create a global network, in
@@ -347,16 +363,17 @@
bug report and it will most probably get one.
The modules are:
AWSMigrationHub, alexaforbusiness, appflow, braket, clouddirectory, comprehend,
- comprehendmedical, connect, datapipeline, datasync, directconnect, discovery, dms, docdb, ds,
- dynamodb, gamelift, glue, groundstation, importexport, kafka, lakeformation, migrationhub-
- config, mq, mturk-requester, neptune, quicksight, redshift, robomaker, sdb, schemas, service-
- quotas, servicecatalog, servicediscovery, signer, sms, snowball, ssm, states, storagegateway,
- support and swf.
+ comprehendmedical, connect, connect-contact-lens, customer-profiles, datapipeline, databrew,
+ datasync, directconnect, discovery, dms, docdb, ds, dynamodb, gamelift, glue, groundstation,
+ healthlake, importexport, kafka, lakeformation, migrationhub-config, mq, mturk-requester,
+ neptune, quicksight, redshift, robomaker, sdb, schemas, service-quotas, servicecatalog,
+ servicediscovery, signer, sms, snowball, ssm, states, storagegateway, support and swf.
</flag>
<flag name="outposts">
AWS Outposts brings native AWS services, infrastructure, and operating models to virtually any
data center, co-location space, or on-premises facility. You can use the same services, tools,
and partner solutions to develop for the cloud and on premises.
+ Also enables s3outposts.
</flag>
<flag name="personalize">
Real-time personalization and recommendations, based on the same technology used at Amazon.com.
@@ -408,7 +425,8 @@
Fully managed machine learning service. With Amazon SageMaker, data scientists and developers
can quickly and easily build and train machine learning models, and then directly deploy them
into a production-ready hosted environment.
- Also enables sagemaker-a2i-runtime and sagemaker-runtime.
+ Also enables sagemaker-a2i-runtime, sagemaker-edge, sagemaker-featurestore-runtime and
+ sagemaker-runtime.
</flag>
<flag name="secretsmanager">
Encrypt, store, and retrieve credentials for databases and other services.
@@ -431,6 +449,11 @@
<flag name="textract">
Amazon Textract to add document text detection and analysis to applications.
</flag>
+ <flag name="timestream">
+ Store and analyze sensor data for IoT applications, metrics for DevOps use cases, and telemetry
+ for application monitoring scenarios such as clickstream data analysis.
+ Note: The two modules enabled are timestream-query and timestream-write.
+ </flag>
<flag name="transcribe">
A transcription services for audio files. It uses advanced machine learning technologies to
recognize spoken words and transcribe them into text.
@@ -445,7 +468,7 @@
CloudFront distributions or an Application Load Balancer. Can also be used to block or allow
requests based on conditions such as the IP addresses that requests originate from or values in
the requests.
- Also enables fms, waf-regional and wafv2
+ Also enables fms, network-firewall, waf-regional and wafv2
</flag>
</use>
</pkgmetadata>