summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-01 17:06:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-01 17:08:33 +0100
commitac8ec5e1b89f51d87708d7a5620464280ef1a484 (patch)
tree18b0d48b8e63b7b3ca17ee7ca1d857d712fbaacc /dev-lang
parentnet-misc/ytfzf: add 2.5.5 (diff)
downloadgentoo-ac8ec5e1b89f51d87708d7a5620464280ef1a484.tar.gz
gentoo-ac8ec5e1b89f51d87708d7a5620464280ef1a484.tar.bz2
gentoo-ac8ec5e1b89f51d87708d7a5620464280ef1a484.zip
dev-lang/python: Silence/fix implicit func decl in 2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.7.18_p16-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-lang/python/python-2.7.18_p16-r1.ebuild b/dev-lang/python/python-2.7.18_p16-r1.ebuild
index 46d496829651..16af9e8af96f 100644
--- a/dev-lang/python/python-2.7.18_p16-r1.ebuild
+++ b/dev-lang/python/python-2.7.18_p16-r1.ebuild
@@ -80,6 +80,8 @@ RDEPEND+="
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
QA_PKGCONFIG_VERSION=${PYVER}
+# false positives -- functions specific to *BSD
+QA_CONFIG_IMPL_DECL_SKIP=( chflags lchflags )
pkg_setup() {
if use berkdb; then
@@ -187,6 +189,9 @@ src_configure() {
# Python on glibc upgrade, remove it proactively to give
# a chance for users rebuilding python before glibc
ac_cv_header_stropts_h=no
+ # Test program has missing includes. This doesn't change
+ # the result but it's cleaner to force it.
+ ac_cv_broken_poll=no
--with-fpectl
--enable-shared