summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-10 18:27:12 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-10 18:43:29 +0200
commita825229371affc2033d003d33afd9a908835fab0 (patch)
treefa868104564476f044bf7835e9813322a8684f35 /dev-lang
parentdev-lang/algol68g: bump to 3.5.6 (diff)
downloadgentoo-a825229371affc2033d003d33afd9a908835fab0.tar.gz
gentoo-a825229371affc2033d003d33afd9a908835fab0.tar.bz2
gentoo-a825229371affc2033d003d33afd9a908835fab0.zip
dev-lang/kotlin-bin: drop old 2.0.10
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/kotlin-bin/Manifest1
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-2.0.10.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
index 323e2b9451f3..c5ccbe2e7d1e 100644
--- a/dev-lang/kotlin-bin/Manifest
+++ b/dev-lang/kotlin-bin/Manifest
@@ -1,2 +1 @@
-DIST kotlin-compiler-2.0.10.zip 83745882 BLAKE2B acd359e348fdb8fbb339a2fcd5fedb165990cc366f0c717644360267aa161e96b8813e0569a0ebc8f2d5de65f25c780c733b6b50c14e8b943344c31a492f0534 SHA512 ba0eac447eb62726604fe9f0d563b1fa8d23001f3ed6053954269e3f342886533a1fa2a8fc4d8f1e7aaae7b94db96a72f195f2b886eb7a50d1e6c25ac80ba106
DIST kotlin-compiler-2.0.20.zip 86110157 BLAKE2B 601e6d8b0ac3af3b8b0b2ddc87bb8ab2d69769e9f3d217c1be317874bfd77a8b767fd84c315637b48782393326bc3b1abc875d1293b3766dc03a0216d26cddf0 SHA512 07bb47339813d127783b2ddfd52635dd483744f1821c8b95075698f37c506e0b66c7abb3d9ab183ba957fe07b4ce1a34b9be2c4477ca0e9115feacab8380bba7
diff --git a/dev-lang/kotlin-bin/kotlin-bin-2.0.10.ebuild b/dev-lang/kotlin-bin/kotlin-bin-2.0.10.ebuild
deleted file mode 100644
index 7e3629cfadfc..000000000000
--- a/dev-lang/kotlin-bin/kotlin-bin-2.0.10.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-pkg-2 wrapper
-
-DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
-HOMEPAGE="https://kotlinlang.org/
- https://github.com/JetBrains/kotlin/"
-SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
-S="${WORKDIR}/kotlinc"
-
-LICENSE="Apache-2.0 BSD MIT NPL-1.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-DEPEND="
- >=virtual/jdk-1.8:*
-"
-BDEPEND="
- app-arch/unzip
-"
-
-src_prepare() {
- default
-
- rm bin/*.bat || die
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- java-pkg_dojar lib/*
-
- # Follow the Java eclass JAR installation path.
- local app_home="/usr/share/${PN}"
-
- exeinto "${app_home}/bin"
- doexe bin/*
-
- local -a exes=(
- kapt
- kotlin
- kotlinc
- kotlinc-js
- kotlinc-jvm
- kotlin-dce-js
- )
- local exe
- for exe in "${exes[@]}" ; do
- make_wrapper "${exe}" "${app_home}/bin/${exe}"
- done
-}