summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-08 13:44:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-08 14:05:40 +0200
commit0c052ffa078b70ae349847484ddd73f127354f79 (patch)
tree3ec5bf1d31c73b816c9581d018cff78229e52909 /dev-lang
parentdev-lang/kotlin-bin: bump to 2.0.10 (diff)
downloadgentoo-0c052ffa078b70ae349847484ddd73f127354f79.tar.gz
gentoo-0c052ffa078b70ae349847484ddd73f127354f79.tar.bz2
gentoo-0c052ffa078b70ae349847484ddd73f127354f79.zip
dev-lang/kotlin-bin: drop old 1.9.24
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/kotlin-bin/Manifest1
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-1.9.24.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
index bebce94257e0..a7bd4fa9f2e4 100644
--- a/dev-lang/kotlin-bin/Manifest
+++ b/dev-lang/kotlin-bin/Manifest
@@ -1,3 +1,2 @@
-DIST kotlin-compiler-1.9.24.zip 91056044 BLAKE2B b872635e83b334cf4b8ee6f2aad5f4d1cf44594848c02a027fd3f7adcffb6d05232e66658ed8e6e234c2ea0996728338f6fdd46628ccfeddeeb5f3b330307340 SHA512 cc6f3cd141faed849f0c8b11b4473f30211d242001292eecc1a0927151034afd892840289457cef6fc8a201dacf157fdb5782cf0a96d27bfa2b3693fac118a84
DIST kotlin-compiler-2.0.0.zip 83767523 BLAKE2B 4627ec2ccf0751baee141a980f14bace98a96b4f826b72f001dc2e27afe1fa60b3967e533e775f7dd81a5e682670cd38c02378884a2d543caca050aee519e765 SHA512 ca723146188a60a995089d4b06bb23c83bfb2dbaabbbad632921601babbccddf4e3f0519692018480b7a0a7a1d0ce3002dcb6f4a445dc2dfa2a2b8f4e39364c7
DIST kotlin-compiler-2.0.10.zip 83745882 BLAKE2B acd359e348fdb8fbb339a2fcd5fedb165990cc366f0c717644360267aa161e96b8813e0569a0ebc8f2d5de65f25c780c733b6b50c14e8b943344c31a492f0534 SHA512 ba0eac447eb62726604fe9f0d563b1fa8d23001f3ed6053954269e3f342886533a1fa2a8fc4d8f1e7aaae7b94db96a72f195f2b886eb7a50d1e6c25ac80ba106
diff --git a/dev-lang/kotlin-bin/kotlin-bin-1.9.24.ebuild b/dev-lang/kotlin-bin/kotlin-bin-1.9.24.ebuild
deleted file mode 100644
index 7e3629cfadfc..000000000000
--- a/dev-lang/kotlin-bin/kotlin-bin-1.9.24.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-pkg-2 wrapper
-
-DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
-HOMEPAGE="https://kotlinlang.org/
- https://github.com/JetBrains/kotlin/"
-SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
-S="${WORKDIR}/kotlinc"
-
-LICENSE="Apache-2.0 BSD MIT NPL-1.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-DEPEND="
- >=virtual/jdk-1.8:*
-"
-BDEPEND="
- app-arch/unzip
-"
-
-src_prepare() {
- default
-
- rm bin/*.bat || die
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- java-pkg_dojar lib/*
-
- # Follow the Java eclass JAR installation path.
- local app_home="/usr/share/${PN}"
-
- exeinto "${app_home}/bin"
- doexe bin/*
-
- local -a exes=(
- kapt
- kotlin
- kotlinc
- kotlinc-js
- kotlinc-jvm
- kotlin-dce-js
- )
- local exe
- for exe in "${exes[@]}" ; do
- make_wrapper "${exe}" "${app_home}/bin/${exe}"
- done
-}