summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <floss@bsd.ac>2021-06-22 19:34:00 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-07-03 18:40:19 +0300
commit77a79765c7e6c8421c5591bd80954098631e3114 (patch)
tree4cecc311f0301e99a3836c81f308f8c60bc662bc /dev-lang/zig
parentdev-lang/zig: version bump to 0.8.0 (diff)
downloadgentoo-77a79765c7e6c8421c5591bd80954098631e3114.tar.gz
gentoo-77a79765c7e6c8421c5591bd80954098631e3114.tar.bz2
gentoo-77a79765c7e6c8421c5591bd80954098631e3114.zip
dev-lang/zig: enable tests for 0.7.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/21296 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/zig')
-rw-r--r--dev-lang/zig/zig-0.7.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-lang/zig/zig-0.7.1.ebuild b/dev-lang/zig/zig-0.7.1.ebuild
index 063604d4ceb1..18ac8c97dc04 100644
--- a/dev-lang/zig/zig-0.7.1.ebuild
+++ b/dev-lang/zig/zig-0.7.1.ebuild
@@ -9,7 +9,8 @@ DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
LICENSE="MIT"
SLOT="0"
-IUSE="+experimental"
+IUSE="+experimental test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/ziglang/zig.git"
@@ -19,6 +20,8 @@ else
KEYWORDS="~amd64"
fi
+BUILD_DIR="${S}/build"
+
# According to zig's author, zig builds that do not support all targets are not
# supported by the upstream project.
ALL_LLVM_TARGETS=(
@@ -50,3 +53,8 @@ src_configure() {
)
cmake_src_configure
}
+
+src_test() {
+ cd "${BUILD_DIR}"
+ ./zig build test || die
+}