summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-14 00:29:02 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-14 01:15:43 -0400
commit99aac9e15f746e89cd8b17f88a9294b45401f149 (patch)
tree6606059ccc7aa134fce5944af8ca86ea2f0b29f6 /dev-lang/yap
parentdev-lang/yap: update HOMEPAGE to web.archive.org (diff)
downloadgentoo-99aac9e15f746e89cd8b17f88a9294b45401f149.tar.gz
gentoo-99aac9e15f746e89cd8b17f88a9294b45401f149.tar.bz2
gentoo-99aac9e15f746e89cd8b17f88a9294b45401f149.zip
dev-lang/yap: do not require python_setup to run if not USE=python
We don't need to check for a python impl, since python itself is optional. This is especially relevant given that it hasn't been migrated to python 3.12, so by default there is no available implementation selected, and python support is also NOT built by default, so this change makes it build by default. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-lang/yap')
-rw-r--r--dev-lang/yap/yap-7.0.1.ebuild4
-rw-r--r--dev-lang/yap/yap-7.1.0.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/yap/yap-7.0.1.ebuild b/dev-lang/yap/yap-7.0.1.ebuild
index 1912376a3191..0960279f31d5 100644
--- a/dev-lang/yap/yap-7.0.1.ebuild
+++ b/dev-lang/yap/yap-7.0.1.ebuild
@@ -47,6 +47,10 @@ DEPEND="${RDEPEND}
java? ( dev-lang/swig )
python? ( dev-lang/swig )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_unpack() {
default
mv "${WORKDIR}"/yap-${PV_COMMIT} "${WORKDIR}"/${P} || die
diff --git a/dev-lang/yap/yap-7.1.0.ebuild b/dev-lang/yap/yap-7.1.0.ebuild
index 9d4b5db24e13..6e867c989e20 100644
--- a/dev-lang/yap/yap-7.1.0.ebuild
+++ b/dev-lang/yap/yap-7.1.0.ebuild
@@ -47,6 +47,10 @@ DEPEND="${RDEPEND}
java? ( dev-lang/swig )
python? ( >=dev-lang/swig-4.0.0 )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_unpack() {
default
mv "${WORKDIR}"/yap-${PV_COMMIT} "${WORKDIR}"/${P} || die