summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-10-20 11:27:02 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-10-20 11:27:02 -0700
commit04c55ce73d0d42dc63399491f939ced1b873832a (patch)
tree63f997bcb23ae9b19b4ee9fd21c1c5fc4f76b824 /dev-lang/rust-bin
parentdev-lang/rust-bin: fix USE=rust-analyzer (diff)
downloadgentoo-04c55ce73d0d42dc63399491f939ced1b873832a.tar.gz
gentoo-04c55ce73d0d42dc63399491f939ced1b873832a.tar.bz2
gentoo-04c55ce73d0d42dc63399491f939ced1b873832a.zip
dev-lang/rust-bin: || die if symlink target not found
Bug: https://bugs.gentoo.org/876979 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust-bin')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.64.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.64.0-r1.ebuild b/dev-lang/rust-bin/rust-bin-1.64.0-r1.ebuild
index e8b145d2a0de..fe1802438234 100644
--- a/dev-lang/rust-bin/rust-bin-1.64.0-r1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.64.0-r1.ebuild
@@ -143,7 +143,7 @@ multilib_src_install() {
# we need realpath on /usr/bin/* symlink return version-appended binary path.
# so /usr/bin/rustc should point to /opt/rust-bin-<ver>/bin/rustc-<ver>
local ver_i="${i}-bin-${PV}"
- ln -v "${ED}/opt/${P}/bin/${i}" "${ED}/opt/${P}/bin/${ver_i}"
+ ln -v "${ED}/opt/${P}/bin/${i}" "${ED}/opt/${P}/bin/${ver_i}" || die
dosym "../../opt/${P}/bin/${ver_i}" "/usr/bin/${ver_i}"
done