summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-04 10:02:44 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-04 10:28:23 +0200
commit3822f85be834f2ecc87c7390897fd923019e3dd8 (patch)
tree33b07b1c3d8ed4931ce14d7de673cdb37cda1ace /dev-lang/python-exec/python-exec-9999.ebuild
parentdev-python/pmw: Updates for eapi7 ebuilds (diff)
downloadgentoo-3822f85be834f2ecc87c7390897fd923019e3dd8.tar.gz
gentoo-3822f85be834f2ecc87c7390897fd923019e3dd8.tar.bz2
gentoo-3822f85be834f2ecc87c7390897fd923019e3dd8.zip
dev-lang/python-exec: EAPI 7, stop using python-r1
Bump to EAPI 7. Replace cheap hack on top of python-r1 with cheap-as-well but probably cleaner hack on top of python-utils-r1. This should silence CI warnings. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python-exec/python-exec-9999.ebuild')
-rw-r--r--dev-lang/python-exec/python-exec-9999.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-lang/python-exec/python-exec-9999.ebuild b/dev-lang/python-exec/python-exec-9999.ebuild
index c0f5a62b4d0b..95c958dd98ec 100644
--- a/dev-lang/python-exec/python-exec-9999.ebuild
+++ b/dev-lang/python-exec/python-exec-9999.ebuild
@@ -1,15 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# Kids, don't do this at home!
-inherit python-utils-r1
-PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
-
-# Inherited purely to have PYTHON_TARGET flags which will satisfy USE
-# dependencies and trigger necessary rebuilds.
-inherit autotools git-r3 python-r1
+inherit autotools git-r3 python-utils-r1
DESCRIPTION="Python script wrapper"
HOMEPAGE="https://github.com/mgorny/python-exec/"
@@ -19,7 +13,8 @@ EGIT_REPO_URI="https://github.com/mgorny/python-exec.git"
LICENSE="BSD-2"
SLOT="2"
KEYWORDS=""
-IUSE=""
+# Internal Python project hack. Do not copy it. Ever.
+IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_}"
# eselect-python because of /usr/bin/python* collisions and new config
# python versions because of missing $scriptdir/python* symlinks
@@ -37,7 +32,7 @@ src_prepare() {
src_configure() {
local pyimpls=() i EPYTHON
- for i in "${PYTHON_COMPAT[@]}"; do
+ for i in "${_PYTHON_ALL_IMPLS[@]}"; do
python_export "${i}" EPYTHON
pyimpls+=( "${EPYTHON}" )
done