summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-lang/ghc
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ghc-8.6.4.ebuild1
-rw-r--r--dev-lang/ghc/ghc-8.6.5.ebuild1
-rw-r--r--dev-lang/ghc/ghc-8.8.1.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/dev-lang/ghc/ghc-8.6.4.ebuild b/dev-lang/ghc/ghc-8.6.4.ebuild
index 85887f1f738a..9400b701afb3 100644
--- a/dev-lang/ghc/ghc-8.6.4.ebuild
+++ b/dev-lang/ghc/ghc-8.6.4.ebuild
@@ -74,6 +74,7 @@ SLOT="0/${PV}"
#will need big tree sync
#KEYWORDS="~amd64 ~x86"
IUSE="doc ghcbootstrap ghcmakebinary +gmp profile test"
+RESTRICT="!test? ( test )"
IUSE+=" binary"
RDEPEND="
diff --git a/dev-lang/ghc/ghc-8.6.5.ebuild b/dev-lang/ghc/ghc-8.6.5.ebuild
index 9ef1702b9c59..63cc1241c218 100644
--- a/dev-lang/ghc/ghc-8.6.5.ebuild
+++ b/dev-lang/ghc/ghc-8.6.5.ebuild
@@ -74,6 +74,7 @@ SLOT="0/${PV}"
# to be rekeyworded when most of revdeps are updated
#KEYWORDS="~amd64 ~x86"
IUSE="doc ghcbootstrap ghcmakebinary +gmp profile test"
+RESTRICT="!test? ( test )"
IUSE+=" binary"
RDEPEND="
diff --git a/dev-lang/ghc/ghc-8.8.1.ebuild b/dev-lang/ghc/ghc-8.8.1.ebuild
index 571fd3176d33..b91c9d0ba44d 100644
--- a/dev-lang/ghc/ghc-8.8.1.ebuild
+++ b/dev-lang/ghc/ghc-8.8.1.ebuild
@@ -73,6 +73,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="doc elfutils ghcbootstrap ghcmakebinary +gmp numa profile test"
+RESTRICT="!test? ( test )"
IUSE+=" binary"
RDEPEND="