summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-11-16 21:28:47 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-11-16 21:30:16 +0100
commit6978c5a64afc8a18bf6567e558f9807f66211bda (patch)
treebde941f6e6edde7780befeb8207a78efd4a3d726 /dev-java
parentsys-apps/systemd: add 255_rc2 (diff)
downloadgentoo-6978c5a64afc8a18bf6567e558f9807f66211bda.tar.gz
gentoo-6978c5a64afc8a18bf6567e558f9807f66211bda.tar.bz2
gentoo-6978c5a64afc8a18bf6567e558f9807f66211bda.zip
dev-java/java-config: add 2.3.3
Closes: https://bugs.gentoo.org/830860 Closes: https://bugs.gentoo.org/909905 Closes: https://bugs.gentoo.org/917326 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-config/Manifest1
-rw-r--r--dev-java/java-config/java-config-2.3.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-java/java-config/Manifest b/dev-java/java-config/Manifest
index b59307d6fd5c..cf19fbf41cb0 100644
--- a/dev-java/java-config/Manifest
+++ b/dev-java/java-config/Manifest
@@ -1,2 +1,3 @@
DIST java-config-2.3.1.tar.gz 26165 BLAKE2B 948506663513db369d0ed8ffdfaa54c643989431430ea03440551a6a4b6725d8eec38f5cb4fde3b64e8936c0f43de0e65a7368469032c646c7b6b3bb7ec3ed13 SHA512 62db555b2d8a37a03b6a03aa133010848d54be33ba6e3c43807abefe665a9d8ff2790baf1af79b98d4a7bd3e9ba6bc64382a24c3fcf7038338123dabd146b7b4
DIST java-config-2.3.2.tar.gz 26297 BLAKE2B 02b3cf34abb48d67189b40478095564b6ca11fceca9fef0a3258c246d451ba793b6f050b3f9435b39c16b9d75802cbd387c8f663301176cac108e35a7bab3f4b SHA512 f00b73a33ccfc824dbc5facd75cd581389c2568e22bad92ed9a088917a3b42058198b547a8cdc6ce40fe3a109eec7c8405131775ad7fcb2eda0dd85d4637c527
+DIST java-config-2.3.3.tar.gz 33837 BLAKE2B dc522a61775272e520521a06c80ac33cbe40010a40051857df8abdbda72cc064969cb00dbf8f7d06efabd352d9cf2c711808205579c7cef73ce4bb7fe2845c8d SHA512 f999ccbdd47f2552913467d3b0c6704fc6511f2bc9d0a6f62d38a9c2e9899f11b239f2039b025f7fdee5e0713d2aaf13c1a9a9baf4f1551bb97d85b12d3f28e9
diff --git a/dev-java/java-config/java-config-2.3.3.ebuild b/dev-java/java-config/java-config-2.3.3.ebuild
new file mode 100644
index 000000000000..a4dc516e9ab8
--- /dev/null
+++ b/dev-java/java-config/java-config-2.3.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-r1
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/java-config.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="Java environment configuration query tool"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="test? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+
+# baselayout-java is added as a dep till it can be added to eclass.
+RDEPEND="
+ ${PYTHON_DEPS}
+ sys-apps/baselayout-java
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+src_configure() {
+ local python_only=false
+ python_foreach_impl my_src_configure
+}
+
+my_src_configure() {
+ local emesonargs=(
+ -Darch="${ARCH}"
+ -Dpython-only="${python_only}"
+ -Deprefix="${EPREFIX}"
+ )
+
+ meson_src_configure
+ python_only=true
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test --no-rebuild --verbose
+}
+
+src_install() {
+ python_foreach_impl my_src_install
+
+ local scripts
+ mapfile -t scripts < <(awk '/^#!.*python/ {print FILENAME} {nextfile}' "${ED}"/usr/bin/* || die)
+ python_replicate_script "${scripts[@]}"
+}
+
+my_src_install() {
+ meson_src_install
+
+ local pydirs=(
+ "${D}$(python_get_sitedir)"
+ )
+ python_optimize "${pydirs[@]}"
+}