summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xmldb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xmldb')
-rw-r--r--dev-java/xmldb/Manifest1
-rw-r--r--dev-java/xmldb/files/build-20011111.xml59
-rw-r--r--dev-java/xmldb/files/xmldb-20011111-unreachable.patch12
-rw-r--r--dev-java/xmldb/metadata.xml14
-rw-r--r--dev-java/xmldb/xmldb-20011111-r1.ebuild56
5 files changed, 142 insertions, 0 deletions
diff --git a/dev-java/xmldb/Manifest b/dev-java/xmldb/Manifest
new file mode 100644
index 000000000000..1acb5cccb3f9
--- /dev/null
+++ b/dev-java/xmldb/Manifest
@@ -0,0 +1 @@
+DIST xmldb-api-11112001.tar.gz 36553 SHA256 9bf195503b6ce45d17e1953041c125602bc69e3f6812a031055d26ca558d1006 SHA512 20123801a57b5350ade4dc82aba5ba2492cfbbe2e0389aaba4b73cdd3a8d07981a895ec2318885358102e48644cdaa30a18996ab9315891e506506fbc25658a2 WHIRLPOOL b96742f2da55b3330c5554c103b9998a69138a71050e9b48b71926df2b41dc92c3449b9f75843e9ba03b16cd480d23b6d2db1d56b29ae39b55a062836047e014
diff --git a/dev-java/xmldb/files/build-20011111.xml b/dev-java/xmldb/files/build-20011111.xml
new file mode 100644
index 000000000000..27e6a4469fc0
--- /dev/null
+++ b/dev-java/xmldb/files/build-20011111.xml
@@ -0,0 +1,59 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!---
+ @author: Saleem Abdulrasool <compnerd@gentoo.org>
+ @date: 5/9/2005
+ @revision: 1.0_alpha
+
+ @notes: Call using the following: ant -f build.xml -Dproject.name=${project name} -Dpackage.name=${package name}
+-->
+
+<project name="Gentoo_Builder" default="jar" basedir=".">
+ <property name="src" value="src"/>
+ <property name="build" value="build"/>
+ <property name="dist" value="dist"/>
+ <property name="project.name" value="xmldb-api"/>
+
+ <property name="pkg" value="${package.name}"/>
+ <property name="jar" value="${project.name}.jar"/>
+ <property name="sdk-jar" value="${project.name}-sdk.jar"/>
+
+ <!-- Override any defined properties -->
+ <property file="build.properties"/>
+
+ <target name="init">
+ <tstamp/>
+ <mkdir dir="${build}"/>
+ <mkdir dir="${dist}"/>
+ <mkdir dir="${dist}/doc"/>
+ </target>
+
+ <target name="compile" depends="init">
+ <javac source="1.4" srcdir="${src}" destdir="${build}" classpath="${classpath}" excludes="**/test"/>
+ </target>
+
+ <target name="manifest" depends="init">
+ <manifest file="${build}/MANIFEST.MF" mode="update">
+ <attribute name="Built-By" value="Gentoo Portage"/>
+ </manifest>
+ </target>
+
+ <target name="jar" depends="compile,manifest">
+ <jar jarfile="${dist}/${jar}" manifest="${build}/MANIFEST.MF">
+ <fileset dir="${build}" includes="org/xmldb/api/*.class,org/xmldb/api/base/**,org/xmldb/api/modules/**"/>
+ </jar>
+ <jar jarfile="${dist}/${sdk-jar}" manifest="${build}/MANIFEST.MF">
+ <fileset dir="${build}" includes="org/xmldb/api/*.class,org/xmldb/api/reference/**,org/xmldb/api/sdk/**"/>
+ </jar>
+ </target>
+
+ <target name="javadoc" depends="compile">
+ <javadoc destdir="${dist}/doc/api" source="1.4">
+ <fileset dir="${src}"/>
+ </javadoc>
+ </target>
+
+ <target name="clean">
+ <delete dir="${build}"/>
+ <delete dir="${dist}"/>
+ </target>
+</project>
diff --git a/dev-java/xmldb/files/xmldb-20011111-unreachable.patch b/dev-java/xmldb/files/xmldb-20011111-unreachable.patch
new file mode 100644
index 000000000000..3e081e6e2d47
--- /dev/null
+++ b/dev-java/xmldb/files/xmldb-20011111-unreachable.patch
@@ -0,0 +1,12 @@
+diff -ru xmldb/org/xmldb/api/reference/modules/XPathQueryServiceImpl.java xmldb-patched/org/xmldb/api/reference/modules/XPathQueryServiceImpl.java
+--- xmldb/org/xmldb/api/reference/modules/XPathQueryServiceImpl.java 2002-01-30 04:46:43.000000000 -0500
++++ xmldb/org/xmldb/api/reference/modules/XPathQueryServiceImpl.java 2005-06-26 21:37:59.000000000 -0400
+@@ -133,7 +133,7 @@
+ }
+ }
+
+- return result;;
++ return result;
+ }
+ }
+
diff --git a/dev-java/xmldb/metadata.xml b/dev-java/xmldb/metadata.xml
new file mode 100644
index 000000000000..2b157ce3b0f5
--- /dev/null
+++ b/dev-java/xmldb/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+XML:DB provides a community for collaborative development of specifications
+for XML databases and data manipulation technologies. Along with each
+specification an open source reference implementation will be developed to
+validate the ideas.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xmldb-org</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/xmldb/xmldb-20011111-r1.ebuild b/dev-java/xmldb/xmldb-20011111-r1.ebuild
new file mode 100644
index 000000000000..b0e125b9859e
--- /dev/null
+++ b/dev-java/xmldb/xmldb-20011111-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 eutils java-ant-2
+
+MY_PN="${PN}-api"
+MY_PV="11112001"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="Java implementation for specifications made by XML:DB"
+HOMEPAGE="http://sourceforge.net/projects/xmldb-org/"
+SRC_URI="mirror://sourceforge/xmldb-org/${MY_P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# TODO please make compiling the junit tests optional
+COMMON_DEP="
+ >=dev-java/xerces-2.7
+ >=dev-java/xalan-2.7
+ =dev-java/junit-3.8*"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -v *.jar || die
+ mkdir lib
+
+ epatch "${FILESDIR}/${P}-unreachable.patch"
+
+ mkdir src && mv org src
+ cp "${FILESDIR}/build-${PV}.xml" build.xml
+}
+
+src_compile() {
+ # --with-dependencies because of indirectly referenced xml-commons-external
+ eant jar $(use_doc) \
+ -Dclasspath=$(java-pkg_getjars --with-dependencies xerces-2,xalan,junit)
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+
+ use doc && java-pkg_dojavadoc dist/doc/api
+ use source && java-pkg_dosrc src/*
+}