summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/lucene-analyzers
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/lucene-analyzers')
-rw-r--r--dev-java/lucene-analyzers/Manifest2
-rw-r--r--dev-java/lucene-analyzers/files/manifest10
-rw-r--r--dev-java/lucene-analyzers/lucene-analyzers-1.9.1-r1.ebuild33
-rw-r--r--dev-java/lucene-analyzers/lucene-analyzers-2.3.2.ebuild28
-rw-r--r--dev-java/lucene-analyzers/metadata.xml10
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-java/lucene-analyzers/Manifest b/dev-java/lucene-analyzers/Manifest
new file mode 100644
index 000000000000..57c0560080ce
--- /dev/null
+++ b/dev-java/lucene-analyzers/Manifest
@@ -0,0 +1,2 @@
+DIST lucene-1.9.1-src.tar.gz 6135056 SHA256 a06bd64ce779f3d4e4b539c280f6a882efb2fd8cba4ebbed02a2b6f92658524f SHA512 fb9f29e0d38d6525d7f6f86d339867a08bfe77ba18a023885a3ecb093d217840c274c767b6e1451f7c58135919c6159122756ebde4640a47420526502395a994 WHIRLPOOL c9d83447742d2d0a2a30e73eb6ed2659db9be77d8bba0de716bdcf73af4bbbf0bf789251a8657c72aed217bf2b2deecb0ce044cf38d1b9a835cf66c338e9d548
+DIST lucene-2.3.2-src.tar.gz 4602041 SHA256 d0cc4b8a40900bbb3243d2e9d9987e0ea0e7d359a2992222bc9acf296b208416 SHA512 42bf988b2eed45ea8d8a3523d9fcf4e384e0e9729a25a54e518a34faf960370a8f7d824f537df7155dc2b64ac11e1b30a8e1ea745a0e054c86722f6e8551360d WHIRLPOOL d8db8e2962624f11e35d69f49a4bf000ebec33a6b01d42e71b5e19cc160c0a29167f94d6b96bd9d45154aa7292469d31c502670bfd0c54e78d333c89e6f33c03
diff --git a/dev-java/lucene-analyzers/files/manifest b/dev-java/lucene-analyzers/files/manifest
new file mode 100644
index 000000000000..9ab3b27d9757
--- /dev/null
+++ b/dev-java/lucene-analyzers/files/manifest
@@ -0,0 +1,10 @@
+Manifest-Version: 1.0
+Bundle-ManifestVersion: 2
+Bundle-Name: %pluginName
+Bundle-Vendor: %vendorName
+Bundle-Localization: plugin
+Export-Package: org.apache.lucene.analysis.br,org.apache.lucene.analysis.cjk,org.apache.lucene.analysis.cn,
+ org.apache.lucene.analysis.cz,org.apache.lucene.analysis.de,org.apache.lucene.analysis.el,org.apache.lucene.analysis.fr,
+ org.apache.lucene.analysis.nl,org.apache.lucene.analysis.ru
+Bundle-SymbolicName: org.apache.lucene.analysis
+Bundle-Version: 1.9.1
diff --git a/dev-java/lucene-analyzers/lucene-analyzers-1.9.1-r1.ebuild b/dev-java/lucene-analyzers/lucene-analyzers-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..bdea7daa5275
--- /dev/null
+++ b/dev-java/lucene-analyzers/lucene-analyzers-1.9.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 java-osgi
+
+MY_PN="${PN/lucene-}"
+MY_P="${P/-${MY_PN}}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Lucene Analyzers additions"
+HOMEPAGE="http://lucene.apache.org/java"
+SRC_URI="mirror://apache/lucene/java/${MY_P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1.9"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.6"
+RDEPEND=">=virtual/jre-1.4"
+
+src_compile() {
+ cd "${S}/contrib/${MY_PN}"
+ eant
+}
+
+src_install() {
+ java-osgi_newjar-fromfile "build/contrib/${MY_PN}/${PN}-1.9.2-dev.jar" \
+ "${FILESDIR}/manifest" "Apache Lucene Analysis"
+
+ use source && java-pkg_dosrc contrib/${MY_PN}/src/java/org
+}
diff --git a/dev-java/lucene-analyzers/lucene-analyzers-2.3.2.ebuild b/dev-java/lucene-analyzers/lucene-analyzers-2.3.2.ebuild
new file mode 100644
index 000000000000..9339292af664
--- /dev/null
+++ b/dev-java/lucene-analyzers/lucene-analyzers-2.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 java-osgi
+
+MY_PN="${PN/lucene-}"
+MY_P="${P/-${MY_PN}}"
+
+DESCRIPTION="Lucene Analyzers additions"
+HOMEPAGE="http://lucene.apache.org/java"
+SRC_URI="mirror://apache/lucene/java/${MY_P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.3"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-linux ~amd64-linux ~ppc-macos"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_P}/contrib/${MY_PN}"
+
+src_install() {
+ java-osgi_newjar-fromfile "${WORKDIR}/${MY_P}/build/contrib/${MY_PN}/${PN}-${SLOT}.jar" \
+ "${FILESDIR}/manifest" "Apache Lucene Analysis"
+
+ use source && java-pkg_dosrc "${S}/src/java/org"
+}
diff --git a/dev-java/lucene-analyzers/metadata.xml b/dev-java/lucene-analyzers/metadata.xml
new file mode 100644
index 000000000000..63e203f20049
--- /dev/null
+++ b/dev-java/lucene-analyzers/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription>
+ Set of analyzers (for various languages) to be used with the Lucene search library.
+ An analyzer's job is to take a string of text and give back a stream of tokens
+ (presumably words).
+</longdescription>
+</pkgmetadata>