summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-24 23:59:00 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-24 23:59:47 +0000
commit912d6784e2f8c6d591490730d51d96f5b48b66e7 (patch)
treeb40c275aea7793c6f4157c9538af80b0c25285ca /dev-java/jcmdline/jcmdline-2.0.0.ebuild
parentdev-libs/libbsd: add ~ia64, wrt bug #569640 (diff)
downloadgentoo-912d6784e2f8c6d591490730d51d96f5b48b66e7.tar.gz
gentoo-912d6784e2f8c6d591490730d51d96f5b48b66e7.tar.bz2
gentoo-912d6784e2f8c6d591490730d51d96f5b48b66e7.zip
dev-java/jcmdline: Version bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/jcmdline/jcmdline-2.0.0.ebuild')
-rw-r--r--dev-java/jcmdline/jcmdline-2.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/jcmdline/jcmdline-2.0.0.ebuild b/dev-java/jcmdline/jcmdline-2.0.0.ebuild
new file mode 100644
index 000000000000..d019da535ac9
--- /dev/null
+++ b/dev-java/jcmdline/jcmdline-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library for parsing/handling of command line parameters"
+HOMEPAGE="http://jcmdline.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jcmdline/${P}.zip"
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+java_prepare() {
+ java-pkg_clean
+ rm -rf testsrc || die
+}