summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-01-23 15:49:29 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-01-23 15:54:10 +0100
commit0c8bed7ac026e9fe6fa3a2629098ae30a8bfc7a7 (patch)
tree659c0bd93f3b10468a964cea054028fb9368f23f /dev-java/eclipse-ecj/eclipse-ecj-4.10.ebuild
parentdev-java/ant-eclipse-ecj-4.10: bump (diff)
downloadgentoo-0c8bed7ac026e9fe6fa3a2629098ae30a8bfc7a7.tar.gz
gentoo-0c8bed7ac026e9fe6fa3a2629098ae30a8bfc7a7.tar.bz2
gentoo-0c8bed7ac026e9fe6fa3a2629098ae30a8bfc7a7.zip
dev-java/eclipse-ecj-4.10: bump
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/eclipse-ecj/eclipse-ecj-4.10.ebuild')
-rw-r--r--dev-java/eclipse-ecj/eclipse-ecj-4.10.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-java/eclipse-ecj/eclipse-ecj-4.10.ebuild b/dev-java/eclipse-ecj/eclipse-ecj-4.10.ebuild
new file mode 100644
index 000000000000..18842971b055
--- /dev/null
+++ b/dev-java/eclipse-ecj/eclipse-ecj-4.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="ecj"
+DMF="R-${PV}-201812060815"
+
+DESCRIPTION="Eclipse Compiler for Java"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops4/${DMF}/${MY_PN}src-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="4.10"
+IUSE="+ant"
+
+COMMON_DEP="
+ app-eselect/eselect-java
+ dev-java/ant-core"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-11"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-11
+ app-arch/unzip"
+PDEPEND="
+ ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
+
+JAVA_JAR_FILENAME="${MY_PN}.jar"
+JAVA_GENTOO_CLASSPATH="ant-core"
+
+S="${WORKDIR}"
+
+# See https://bugs.eclipse.org/bugs/show_bug.cgi?id=479134 for details
+java_prepare() {
+ # These have their own package.
+ rm org/eclipse/jdt/core/JDTCompilerAdapter.java || die
+ rm -r org/eclipse/jdt/internal/antadapter || die
+
+ # JavaCore is not distributed in the jar
+ sed -i -e '/import org.eclipse.jdt.core.JavaCore;/d' \
+ -e 's|JavaCore.getOptions()||g' \
+ org/eclipse/jdt/internal/compiler/batch/ClasspathDirectory.java
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ find org META-INF -type f ! -name "*.java" | xargs jar uvf "${JAVA_JAR_FILENAME}" || die "jar update failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${MY_PN}-${SLOT} --main \
+ org.eclipse.jdt.internal.compiler.batch.Main
+}
+
+pkg_postinst() {
+ einfo "To select between slots of ECJ..."
+ einfo " # eselect ecj"
+
+ eselect ecj update ecj-${SLOT}
+}
+
+pkg_postrm() {
+ eselect ecj update
+}