summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-02-28 18:39:36 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-02-28 18:43:03 +0000
commit546abd38b574f129a5ede51c57f785c8ff23d870 (patch)
tree4bc44298b02eab8f6d791c8b42e40e511f51dda4 /dev-haskell
parentdev-python/httpx: Bump to 0.17.0 (diff)
downloadgentoo-546abd38b574f129a5ede51c57f785c8ff23d870.tar.gz
gentoo-546abd38b574f129a5ede51c57f785c8ff23d870.tar.bz2
gentoo-546abd38b574f129a5ede51c57f785c8ff23d870.zip
dev-haskell/alut: fix USE=example for modern GHC
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/773379 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/alut/alut-2.4.0.3.ebuild4
-rw-r--r--dev-haskell/alut/files/alut-2.4.0.3-ghc-8.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/dev-haskell/alut/alut-2.4.0.3.ebuild b/dev-haskell/alut/alut-2.4.0.3.ebuild
index 28bf060d07a5..a85bd82de5f4 100644
--- a/dev-haskell/alut/alut-2.4.0.3.ebuild
+++ b/dev-haskell/alut/alut-2.4.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,6 +32,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+PATCHES=("${FILESDIR}"/${PN}-2.4.0.3-ghc-8.patch)
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag examples buildexamples) \
diff --git a/dev-haskell/alut/files/alut-2.4.0.3-ghc-8.patch b/dev-haskell/alut/files/alut-2.4.0.3-ghc-8.patch
new file mode 100644
index 000000000000..dd8a512d3efa
--- /dev/null
+++ b/dev-haskell/alut/files/alut-2.4.0.3-ghc-8.patch
@@ -0,0 +1,10 @@
+--- a/examples/Basic/OpenALInfo.hs
++++ b/examples/Basic/OpenALInfo.hs
+@@ -7,6 +7,7 @@
+
+ import Text.PrettyPrint
+ import Sound.ALUT
++import Prelude hiding ((<>))
+
+ -- This program prints some basic information about ALC and AL.
+