summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-02 22:37:21 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-02 22:41:22 +0100
commit23bef3455b23be9a6f38ff992b9c4114b0112222 (patch)
tree7ad0315bf5a4c12fc8c2f62c88f57550eecb84b3 /dev-haskell
parentdev-perl/YAML-Syck: Version bump (diff)
downloadgentoo-23bef3455b23be9a6f38ff992b9c4114b0112222.tar.gz
gentoo-23bef3455b23be9a6f38ff992b9c4114b0112222.tar.bz2
gentoo-23bef3455b23be9a6f38ff992b9c4114b0112222.zip
dev-haskell/quickcheck: rename IUSE from underscores to dashes
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/695038 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/quickcheck/metadata.xml2
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.6.ebuild6
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.7.6.ebuild8
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.8.1.ebuild8
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.8.2.ebuild6
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.9.2.ebuild10
6 files changed, 20 insertions, 20 deletions
diff --git a/dev-haskell/quickcheck/metadata.xml b/dev-haskell/quickcheck/metadata.xml
index d5aff4a020bb..120011b0413e 100644
--- a/dev-haskell/quickcheck/metadata.xml
+++ b/dev-haskell/quickcheck/metadata.xml
@@ -6,7 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="template_haskell">Enable additional test modules requiring Template Haskell support.</flag>
+ <flag name="template-haskell">Enable additional test modules requiring Template Haskell support.</flag>
</use>
<longdescription>
QuickCheck is a library for random testing of program properties.
diff --git a/dev-haskell/quickcheck/quickcheck-2.6.ebuild b/dev-haskell/quickcheck/quickcheck-2.6.ebuild
index e362bb8b3e28..c83c7d97c400 100644
--- a/dev-haskell/quickcheck/quickcheck-2.6.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,7 +18,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
RDEPEND="dev-haskell/extensible-exceptions:=[profile?]
dev-haskell/random:=[profile?]
@@ -30,5 +30,5 @@ S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag template_haskell templatehaskell)
+ $(cabal_flag template-haskell templatehaskell)
}
diff --git a/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
index 0d9bfb69fc61..a15e1fbef4cb 100644
--- a/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.7.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
# ebuild generated by hackport 0.4.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
RDEPEND="dev-haskell/random:=[profile?]
>=dev-haskell/tf-random-0.4:=[profile?]
@@ -37,5 +37,5 @@ src_configure() {
haskell-cabal_src_configure \
--flag=-base3 \
--flag=base4 \
- $(cabal_flag template_haskell templatehaskell)
+ $(cabal_flag template-haskell templatehaskell)
}
diff --git a/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild b/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
index b6f22e236bdc..8a9db261e6aa 100644
--- a/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
# ebuild generated by hackport 0.4.4.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
RDEPEND="dev-haskell/random:=[profile?]
>=dev-haskell/tf-random-0.4:=[profile?]
@@ -37,5 +37,5 @@ src_configure() {
haskell-cabal_src_configure \
--flag=-base3 \
--flag=base4 \
- $(cabal_flag template_haskell templatehaskell)
+ $(cabal_flag template-haskell templatehaskell)
}
diff --git a/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild
index a1fe598d4e75..6c00030de7f8 100644
--- a/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.8.2.ebuild
@@ -4,7 +4,7 @@
EAPI=5
# ebuild generated by hackport 0.4.6.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
RESTRICT=test # to avoid test circular depends
@@ -39,5 +39,5 @@ src_configure() {
haskell-cabal_src_configure \
--flag=-base3 \
--flag=base4 \
- $(cabal_flag template_haskell templatehaskell)
+ $(cabal_flag template-haskell templatehaskell)
}
diff --git a/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
index 87803b71b443..db4778bb98b3 100644
--- a/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
+++ b/dev-haskell/quickcheck/quickcheck-2.9.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
# ebuild generated by hackport 0.5.9999
-#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+#hackport: flags: +base4,-base3,templatehaskell:template-haskell
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -19,7 +19,7 @@ SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="amd64 x86 ~x86-fbsd ~amd64-linux"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
RESTRICT=test # to avoid test circular depends
@@ -31,7 +31,7 @@ RDEPEND=">=dev-haskell/nats-1:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
- test? ( template_haskell? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 ) )
+ test? ( template-haskell? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 ) )
"
S="${WORKDIR}/${MY_P}"
@@ -40,5 +40,5 @@ src_configure() {
haskell-cabal_src_configure \
--flag=-base3 \
--flag=base4 \
- $(cabal_flag template_haskell templatehaskell)
+ $(cabal_flag template-haskell templatehaskell)
}