summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/x11
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/x11')
-rw-r--r--dev-haskell/x11/Manifest2
-rw-r--r--dev-haskell/x11/metadata.xml17
-rw-r--r--dev-haskell/x11/x11-1.6.1.1.ebuild41
-rw-r--r--dev-haskell/x11/x11-1.6.1.2.ebuild42
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-haskell/x11/Manifest b/dev-haskell/x11/Manifest
new file mode 100644
index 000000000000..970af42b5728
--- /dev/null
+++ b/dev-haskell/x11/Manifest
@@ -0,0 +1,2 @@
+DIST X11-1.6.1.1.tar.gz 188628 SHA256 7ce575c613786c73efb20d5680a9e572aa1f1c91c3963e285011235759b76eae SHA512 d5f58a7ab2450e145e890187e8dc7b43e286d2a95414a605e549cbf48568ef0d89f662870b2010eecba3b8fdd2a3a57214d33fc8775426e7e23ffad727b4e144 WHIRLPOOL 30027638eb419052d8497594a64fdbcb2bc6d90de95d6ae869a03ee8a1ce3d8aa8d5064c1d10636c203f5e992c6389cfde67865d402d00beb532b9bf94b9d98b
+DIST X11-1.6.1.2.tar.gz 188612 SHA256 5216d485f807bd53bf34fba170896a8930290a6ac28b8e611c28e751ad67f2cf SHA512 f8d01c806f59a20ad6d6632367b80ca972ebc2df9ba65fe23338d5fa1b933049c08609d25be690d87ba6dbe9cd1ba0f5a95e491c8abaca9eaec078ca03e0e01b WHIRLPOOL 03a22e04df736590336cb805e23505b9dd1c64e9bb8171af3e1b9ce82648a39b3f4f288475c680b11732af54eedf1671c17b0d5fab91bcdd7c3202198c0130e0
diff --git a/dev-haskell/x11/metadata.xml b/dev-haskell/x11/metadata.xml
new file mode 100644
index 000000000000..972d01a5574a
--- /dev/null
+++ b/dev-haskell/x11/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A Haskell binding to the X11 graphics library.
+ The binding is a direct translation of the C binding; for
+ documentation of these calls, refer to "The Xlib Programming
+ Manual", available online at &lt;http://tronche.com/gui/x/xlib/&gt;.
+ </longdescription>
+ <use>
+ <flag name="screensaver">whether to build XScreenSaver.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">haskell-pkg-janitors/X11</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/x11/x11-1.6.1.1.ebuild b/dev-haskell/x11/x11-1.6.1.1.ebuild
new file mode 100644
index 000000000000..5650501e2024
--- /dev/null
+++ b/dev-haskell/x11/x11-1.6.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="https://github.com/haskell-pkg-janitors/X11"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="+screensaver +xinerama"
+
+RDEPEND="dev-haskell/data-default:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ screensaver? ( x11-libs/libXScrnSaver )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --configure-option=$(use_with xinerama) \
+ --configure-option=$(use_with screensaver xscreensaver)
+}
diff --git a/dev-haskell/x11/x11-1.6.1.2.ebuild b/dev-haskell/x11/x11-1.6.1.2.ebuild
new file mode 100644
index 000000000000..b946742734dc
--- /dev/null
+++ b/dev-haskell/x11/x11-1.6.1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="https://github.com/haskell-pkg-janitors/X11"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="+screensaver +xinerama"
+
+RDEPEND="dev-haskell/data-default:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ screensaver? ( x11-libs/libXScrnSaver )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --configure-option=$(use_with xinerama) \
+ --configure-option=$(use_with screensaver xscreensaver)
+}