summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:46 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:08 +0100
commit1d775fe4670ba14b25e3640aef72f850ac1a2779 (patch)
treeb7e2c8600cd1224f63d06312b7b480d47908edc7 /dev-haskell/statevar
parentdev-haskell/splitmix: add 0.1.0.4 (diff)
downloadgentoo-1d775fe4670ba14b25e3640aef72f850ac1a2779.tar.gz
gentoo-1d775fe4670ba14b25e3640aef72f850ac1a2779.tar.bz2
gentoo-1d775fe4670ba14b25e3640aef72f850ac1a2779.zip
dev-haskell/statevar: add 1.2.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/statevar')
-rw-r--r--dev-haskell/statevar/Manifest1
-rw-r--r--dev-haskell/statevar/metadata.xml5
-rw-r--r--dev-haskell/statevar/statevar-1.2.2.ebuild26
3 files changed, 28 insertions, 4 deletions
diff --git a/dev-haskell/statevar/Manifest b/dev-haskell/statevar/Manifest
index 2d30ef76a040..072a384fd59e 100644
--- a/dev-haskell/statevar/Manifest
+++ b/dev-haskell/statevar/Manifest
@@ -1 +1,2 @@
DIST StateVar-1.2.1.tar.gz 5055 BLAKE2B 45a9e509deec9988debdf906bfcb3f3fcd04fbd42326ea5eb74b697fa761d2d4a696c84deb0d5634aac0a4d57af3ef56cf612b343afb53f00c2eec4b96d53801 SHA512 867e38b309a0cbb5a3aac1183b6388aab6e546cda799b0668f3e9534556df4b73558295a706b2859c1edb20e89dac7bf8c4f04f839d40ede2c36a2ae7eab6259
+DIST statevar-1.2.2.tar.gz 5048 BLAKE2B 937617e283038101ef8dea2ec62ba77af2f34868b99bbb41241fd07a897d51d31238eaae688239cc0b560d39f34873eeed9226e96b09d659350337e8dfd2ce02 SHA512 d4330b43471ed73e2c70e0686575f7987f617ae1c03d9d5b0ea89d5ec55be2470b6d917e4ecc6d52c4d46fc8afbeea16194667815ce0bbecb1f637d7277f86e6
diff --git a/dev-haskell/statevar/metadata.xml b/dev-haskell/statevar/metadata.xml
index 55a9b1c8d820..a03fe8b48850 100644
--- a/dev-haskell/statevar/metadata.xml
+++ b/dev-haskell/statevar/metadata.xml
@@ -5,11 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package contains state variables, which are references in the IO monad,
- like IORefs or parts of the OpenGL state.
- </longdescription>
<upstream>
+ <remote-id type="hackage">StateVar</remote-id>
<remote-id type="github">haskell-opengl/StateVar</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/statevar/statevar-1.2.2.ebuild b/dev-haskell/statevar/statevar-1.2.2.ebuild
new file mode 100644
index 000000000000..be0ecb11ce35
--- /dev/null
+++ b/dev-haskell/statevar/statevar-1.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_PN="StateVar"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="State variables"
+HOMEPAGE="https://github.com/haskell-opengl/StateVar"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/stm-2.3.0.1:=[profile?] <dev-haskell/stm-2.6:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"