summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:19 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:32 +0100
commit97ff34871204c20b181fce89e548580112b90768 (patch)
treeeadb0bcc83fc1b4b45c48e0405d0c93c3ba0eb46 /dev-haskell/markdown-unlit
parentdev-haskell/fast-logger: add 3.2.2 (diff)
downloadgentoo-97ff34871204c20b181fce89e548580112b90768.tar.gz
gentoo-97ff34871204c20b181fce89e548580112b90768.tar.bz2
gentoo-97ff34871204c20b181fce89e548580112b90768.zip
dev-haskell/markdown-unlit: add 0.6.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/markdown-unlit')
-rw-r--r--dev-haskell/markdown-unlit/Manifest1
-rw-r--r--dev-haskell/markdown-unlit/files/markdown-unlit-0.5.1-add-executable-flag.patch23
-rw-r--r--dev-haskell/markdown-unlit/markdown-unlit-0.6.0.ebuild40
-rw-r--r--dev-haskell/markdown-unlit/metadata.xml7
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/markdown-unlit/Manifest b/dev-haskell/markdown-unlit/Manifest
index 6790b5298bb4..422e7476ad38 100644
--- a/dev-haskell/markdown-unlit/Manifest
+++ b/dev-haskell/markdown-unlit/Manifest
@@ -1 +1,2 @@
DIST markdown-unlit-0.5.0.tar.gz 4681 BLAKE2B cde0d867185c714e0c5d3c76e0baed4b1f7df4f0b85170e3d69476149caa5dd06f7de181e750eee357543ebc2d8e4178d711bee903bd41a5085c75057c9374c8 SHA512 580b4e4a4fcccf845c3e618b2ebc425dd8dba024c1c8bbae8db00a3e4b768353fe6738195dad80ae2afb1a46fcfad46cbed6d98bea1017ef098366fa7a2633ea
+DIST markdown-unlit-0.6.0.tar.gz 5201 BLAKE2B fe5e50cd6df156b1db92859099681f2c6796cc2557144b771819ca215cc171dc5f6dd4d11a15fe24da9ac18e92e925b5e2199e6b85b7d789e4167812028e1c0f SHA512 a1d7179ee82635c5fc07a39fd47b8ec288b260844ac3a90038ea97c7a22c170f2e9db0c72ad538242cbe1ae23b75fd27319650142d0f5bf47793954c3b45639a
diff --git a/dev-haskell/markdown-unlit/files/markdown-unlit-0.5.1-add-executable-flag.patch b/dev-haskell/markdown-unlit/files/markdown-unlit-0.5.1-add-executable-flag.patch
new file mode 100644
index 000000000000..3a40c845652e
--- /dev/null
+++ b/dev-haskell/markdown-unlit/files/markdown-unlit-0.5.1-add-executable-flag.patch
@@ -0,0 +1,23 @@
+From: hololeap <hololeap@protonmail.com>
+Signed-off-by: hololeap <hololeap@protonmail.com>
+
+Add new USE flag: executable
+This toggles building the executable. Since this seems to be the primary
+purpose of the package, it is enabled by default.
+
+--- markdown-unlit-0.5.1/markdown-unlit.cabal.bak 2021-08-28 01:55:59.160717350 -0600
++++ markdown-unlit-0.5.1/markdown-unlit.cabal 2021-08-28 01:58:49.820717433 -0600
+@@ -35,7 +35,13 @@
+ Paths_markdown_unlit
+ default-language: Haskell2010
+
++flag executable
++ description: Build executable
++ default: True
++
+ executable markdown-unlit
++ if !flag(executable)
++ buildable: False
+ main-is: Main.hs
+ other-modules:
+ Paths_markdown_unlit
diff --git a/dev-haskell/markdown-unlit/markdown-unlit-0.6.0.ebuild b/dev-haskell/markdown-unlit/markdown-unlit-0.6.0.ebuild
new file mode 100644
index 000000000000..f26205873cf5
--- /dev/null
+++ b/dev-haskell/markdown-unlit/markdown-unlit-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Literate Haskell support for Markdown"
+HOMEPAGE="https://github.com/sol/markdown-unlit#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+executable"
+
+RDEPEND="
+ dev-haskell/base-compat:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ =dev-haskell/hspec-2*
+ dev-haskell/quickcheck
+ dev-haskell/silently
+ dev-haskell/stringbuilder
+ dev-haskell/temporary
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.1-add-executable-flag.patch" )
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/markdown-unlit/metadata.xml b/dev-haskell/markdown-unlit/metadata.xml
index 937381521944..ff003871f22c 100644
--- a/dev-haskell/markdown-unlit/metadata.xml
+++ b/dev-haskell/markdown-unlit/metadata.xml
@@ -5,4 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <use>
+ <flag name="executable">Build executable</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">markdown-unlit</remote-id>
+ <remote-id type="github">sol/markdown-unlit</remote-id>
+ </upstream>
</pkgmetadata>