summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:23 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:04 +0100
commit169bcff48be6972ebb64fff54948bae9e8aad5e3 (patch)
tree166aa90f570b7dcc8ae7fb4c9b197140ce74b67f /dev-haskell/hslua
parentdev-haskell/hslua-packaging: add 2.3.0 (diff)
downloadgentoo-169bcff48be6972ebb64fff54948bae9e8aad5e3.tar.gz
gentoo-169bcff48be6972ebb64fff54948bae9e8aad5e3.tar.bz2
gentoo-169bcff48be6972ebb64fff54948bae9e8aad5e3.zip
dev-haskell/hslua: add 2.3.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hslua')
-rw-r--r--dev-haskell/hslua/Manifest1
-rw-r--r--dev-haskell/hslua/hslua-2.3.0.ebuild50
-rw-r--r--dev-haskell/hslua/metadata.xml4
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/hslua/Manifest b/dev-haskell/hslua/Manifest
index 2f837f6c1060..12918e9307d4 100644
--- a/dev-haskell/hslua/Manifest
+++ b/dev-haskell/hslua/Manifest
@@ -1 +1,2 @@
DIST hslua-2.2.0.tar.gz 17278 BLAKE2B eda496aa4a2bd89fd0be2fcefa0b1554a931c7876f5b2e456fb315a72d304050f8d9b2ad5ee583c15f4b31dc26f1a87370c526626d8dbed1e2fc5660ee66667e SHA512 cdd4ff872557ba014bb6f64a592702820e9274456c35b9f9c42fccbd279b2157b3087a5040be2bad03890934bf682c7f4d066232480e8243d5259f871514346a
+DIST hslua-2.3.0.tar.gz 17387 BLAKE2B 298ca26eed54c508621596efd90b0c8c7f0151ff9ab5a4d61d8e10fe57b2b61a865b39fcf7b6f12087a6fe913a0f6fb1e01b37aa2ae7c7e4aab58f434aafcac7 SHA512 a3e4bd970d0a55465aafff91f6b03d29443599d819a48dc9f3296bcac5807c9cb2920cb5c6c5e3bda854403a5bea219b9a626305d932f8c452ff9cc09572d060
diff --git a/dev-haskell/hslua/hslua-2.3.0.ebuild b/dev-haskell/hslua/hslua-2.3.0.ebuild
new file mode 100644
index 000000000000..0e681552783c
--- /dev/null
+++ b/dev-haskell/hslua/hslua-2.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+#hackport: flags: -allow-unsafe-gc,-apicheck,-export-dynamic,-lua501,-lua502,-lua_32bits,-system-lua,-pkg-config
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to Lua, an embeddable scripting language"
+HOMEPAGE="https://hslua.org/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/hslua-aeson-2.3:=[profile?] <dev-haskell/hslua-aeson-2.4:=[profile?]
+ >=dev-haskell/hslua-classes-2.2:=[profile?] <dev-haskell/hslua-classes-2.4:=[profile?]
+ >=dev-haskell/hslua-core-2.3:=[profile?] <dev-haskell/hslua-core-2.4:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.3:=[profile?] <dev-haskell/hslua-marshalling-2.4:=[profile?]
+ >=dev-haskell/hslua-objectorientation-2.3:=[profile?] <dev-haskell/hslua-objectorientation-2.4:=[profile?]
+ >=dev-haskell/hslua-packaging-2.3:=[profile?] <dev-haskell/hslua-packaging-2.4:=[profile?]
+ >=dev-haskell/hslua-typing-0.1:=[profile?] <dev-haskell/hslua-typing-0.2:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/lua-2.0
+ >=dev-haskell/lua-arbitrary-1.0
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.11
+ dev-haskell/tasty-hslua
+ >=dev-haskell/tasty-hunit-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-allow-unsafe-gc \
+ --flag=-apicheck \
+ --flag=-export-dynamic \
+ --flag=-lua501 \
+ --flag=-lua502 \
+ --flag=-lua_32bits \
+ --flag=-pkg-config \
+ --flag=-system-lua
+}
diff --git a/dev-haskell/hslua/metadata.xml b/dev-haskell/hslua/metadata.xml
index 937381521944..3b4e9a667d84 100644
--- a/dev-haskell/hslua/metadata.xml
+++ b/dev-haskell/hslua/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">hslua</remote-id>
+ <remote-id type="github">hslua/hslua</remote-id>
+ </upstream>
</pkgmetadata>