summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:13 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:31 +0100
commit2f51f66adbbf405749b8391f23a6c2adb1cf2722 (patch)
treeded68ef94debdf1a2b6fe9f5a5a5e2e1e54497a8 /dev-haskell/entropy
parentdev-haskell/emojis: add 0.1.3 (diff)
downloadgentoo-2f51f66adbbf405749b8391f23a6c2adb1cf2722.tar.gz
gentoo-2f51f66adbbf405749b8391f23a6c2adb1cf2722.tar.bz2
gentoo-2f51f66adbbf405749b8391f23a6c2adb1cf2722.zip
dev-haskell/entropy: add 0.4.1.10
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/entropy')
-rw-r--r--dev-haskell/entropy/Manifest2
-rw-r--r--dev-haskell/entropy/entropy-0.4.1.10.ebuild30
-rw-r--r--dev-haskell/entropy/metadata.xml12
3 files changed, 38 insertions, 6 deletions
diff --git a/dev-haskell/entropy/Manifest b/dev-haskell/entropy/Manifest
index 1297b08b5444..da4dd15454f2 100644
--- a/dev-haskell/entropy/Manifest
+++ b/dev-haskell/entropy/Manifest
@@ -1 +1,3 @@
+DIST entropy-0.4.1.10-rev1.cabal 2952 BLAKE2B f47134454269b5fbb554feec81ff6eccd66290fedd2615ea424ffe4dbaa955930310c575c64b006e6827586724bdc9358fadaf1f54ecfa0d872b3852556f07d6 SHA512 d384d2aeb12d2484455b4be8ee68f9a29dcdd949e62aa0f9baf81d9326cd189d6938b7baf35b0db0e70e2a954a9677611a6193607ede3366d26351c7ee74efc6
+DIST entropy-0.4.1.10.tar.gz 9060 BLAKE2B f1f9d80af0e8ad7d9bf34f8d13af6323ac530ec294d5d7ea5484cddf087b271638daf25f8b119ce426bfebae4f9d5d2a430b316fc4c01c5b282ff6a0a0bda9e6 SHA512 521dded7ae41cc532993236d0ced394f98f495c0c8950201064d17430ee6599d9cd6f3a4f17a19429396ee4a34a3fa17b39af49f4fee730efdae3d42d134c96e
DIST entropy-0.4.1.6.tar.gz 9464 BLAKE2B 484e72ba8b6413b6205db4660f52d183dcd075bce836de6b339e2019d584a90b9f650d6b808b46855c9a423e41f21d814e10026efec050f507edc68106568893 SHA512 201a75efe210be5728a1c94ba9ec62514b96c388b6791d9301b34d2fce0208a9fa4ef25965c7840d052fd6221f15a1bec196a6eb209e6d03c3e1f971161df1b1
diff --git a/dev-haskell/entropy/entropy-0.4.1.10.ebuild b/dev-haskell/entropy/entropy-0.4.1.10.ebuild
new file mode 100644
index 000000000000..ac64d0821c9e
--- /dev/null
+++ b/dev-haskell/entropy/entropy-0.4.1.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A platform independent entropy source"
+HOMEPAGE="https://github.com/TomMD/entropy"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="donotgetentropy"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0 <dev-haskell/cabal-3.11
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag donotgetentropy donotgetentropy)
+}
diff --git a/dev-haskell/entropy/metadata.xml b/dev-haskell/entropy/metadata.xml
index 7c276f275a7c..9cfa8f15bfcb 100644
--- a/dev-haskell/entropy/metadata.xml
+++ b/dev-haskell/entropy/metadata.xml
@@ -5,16 +5,16 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A platform independent method to obtain cryptographically strong entropy
- (RDRAND when available anywhere, urandom on nix, CryptAPI on Windows, patches welcome).
- Users looking for cryptographically strong (number-theoretically
- sound) PRNGs should see the 'DRBG' package too.
- </longdescription>
<use>
+ <flag name="donotgetentropy">
+ Avoid use of the getentropy() *nix function. By default
+ getentropy will be used if detected during compilation
+ (this plays poorly with cross compilation).
+ </flag>
<flag name="halvm">Build for the HaLVM.</flag>
</use>
<upstream>
+ <remote-id type="hackage">entropy</remote-id>
<remote-id type="github">TomMD/entropy</remote-id>
</upstream>
</pkgmetadata>