summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/doctest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/doctest')
-rw-r--r--dev-haskell/doctest/Manifest3
-rw-r--r--dev-haskell/doctest/doctest-0.10.1.ebuild35
-rw-r--r--dev-haskell/doctest/doctest-0.9.12.ebuild35
-rw-r--r--dev-haskell/doctest/doctest-0.9.9.ebuild35
-rw-r--r--dev-haskell/doctest/metadata.xml16
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-haskell/doctest/Manifest b/dev-haskell/doctest/Manifest
new file mode 100644
index 000000000000..7bbf770c1bd4
--- /dev/null
+++ b/dev-haskell/doctest/Manifest
@@ -0,0 +1,3 @@
+DIST doctest-0.10.1.tar.gz 18046 SHA256 357b99c0975171a61de3bf5a9b9265e82a15f336f2ceb5cf73d94111d7877ec9 SHA512 f12d3f30c6dcdd9e088362039b4d99d6b9fb499d0a78016e1e6e7b54968950490a1418dd5a7d94d5f509a08f3cf3111276ac15e84775278a77737099ac9bfd67 WHIRLPOOL 3fab795075d40e48795ad2df8bba6fea44c0d6219488794f9d1668aac08a917774b82702c0a3da3f404b837a76a1491a5eae57685d6c293cf676c7e613bc3cb0
+DIST doctest-0.9.12.tar.gz 15806 SHA256 a3e0e67d7f18572128d7de9b2c55e1559b689e77f6b254c659cc5cb47029756b SHA512 9d0d24ddba3f4ddaa386dc4ea7f15483f4d756dd48f62bcc8cad6e375c57a5660d8c7a12ff5bbc803bde04d65d8a28d3940cc390cd0d2ced2c5cc9895eba7916 WHIRLPOOL 200938a9ac2ebde5279b167da7f2b43c341d670702da5831bdf78de789719c6fc66c551f6b0a32196c0407df3e90e3e3ac249b49e53cc3708ac831bb87b66c53
+DIST doctest-0.9.9.tar.gz 15707 SHA256 fe5dc35e0344772b210aede6a5a01e205b7205d91718f87c63646903596d32e4 SHA512 890aec3fc6a07886e28c98530926206a3d1133422299a8a63ca3adb1b006d556beb3a77011bff2560731533355fbb57299ff1f188a8af2c37badee76770cad22 WHIRLPOOL 467cdcdb14f5d6e0613f70b37215b91987a03a2e287265cbe0475b7e677851549847df06d80829c6ec5cfef5b8ad5fc10fca35fbf1b6208a77a0e11326df6421
diff --git a/dev-haskell/doctest/doctest-0.10.1.ebuild b/dev-haskell/doctest/doctest-0.10.1.ebuild
new file mode 100644
index 000000000000..cd0113b2fa11
--- /dev/null
+++ b/dev-haskell/doctest/doctest-0.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Test interactive Haskell examples"
+HOMEPAGE="https://github.com/sol/doctest#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ghc-paths-0.1.0.9:=[profile?]
+ >=dev-haskell/syb-0.3:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/base-compat-0.4.2
+ >=dev-haskell/hspec-1.5.1
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/setenv
+ >=dev-haskell/silently-1.2.4
+ >=dev-haskell/stringbuilder-0.4 )
+"
diff --git a/dev-haskell/doctest/doctest-0.9.12.ebuild b/dev-haskell/doctest/doctest-0.9.12.ebuild
new file mode 100644
index 000000000000..baa7a91850f3
--- /dev/null
+++ b/dev-haskell/doctest/doctest-0.9.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Test interactive Haskell examples"
+HOMEPAGE="https://github.com/sol/doctest#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ghc-paths-0.1.0.9:=[profile?]
+ >=dev-haskell/syb-0.3:=[profile?] <dev-haskell/syb-0.5:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/base-compat-0.4.2
+ >=dev-haskell/hspec-1.5.1
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/setenv
+ >=dev-haskell/silently-1.2.4
+ >=dev-haskell/stringbuilder-0.4 )
+"
diff --git a/dev-haskell/doctest/doctest-0.9.9.ebuild b/dev-haskell/doctest/doctest-0.9.9.ebuild
new file mode 100644
index 000000000000..a8da33a41f6a
--- /dev/null
+++ b/dev-haskell/doctest/doctest-0.9.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Test interactive Haskell examples"
+HOMEPAGE="https://github.com/sol/doctest-haskell#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ghc-paths-0.1.0.9:=[profile?]
+ >=dev-haskell/syb-0.3:=[profile?] <dev-haskell/syb-0.5:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/base-compat-0.2.1
+ >=dev-haskell/hspec-1.5.1
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/setenv
+ >=dev-haskell/silently-1.2.4
+ >=dev-haskell/stringbuilder-0.4 )
+"
diff --git a/dev-haskell/doctest/metadata.xml b/dev-haskell/doctest/metadata.xml
new file mode 100644
index 000000000000..dffd0ab6329c
--- /dev/null
+++ b/dev-haskell/doctest/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The doctest program checks examples in source code comments.
+ It is modeled after doctest for Python
+ (&lt;http://docs.python.org/library/doctest.html&gt;).
+
+ Documentation is at
+ &lt;https://github.com/sol/doctest-haskell#readme&gt;.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sol/doctest-haskell#readme</remote-id>
+ </upstream>
+</pkgmetadata>