summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/go-crypto
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/go-crypto')
-rw-r--r--dev-go/go-crypto/Manifest1
-rw-r--r--dev-go/go-crypto/go-crypto-0_pre20150608.ebuild61
-rw-r--r--dev-go/go-crypto/go-crypto-9999.ebuild39
-rw-r--r--dev-go/go-crypto/metadata.xml10
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-go/go-crypto/Manifest b/dev-go/go-crypto/Manifest
new file mode 100644
index 000000000000..072c0b3c4f4a
--- /dev/null
+++ b/dev-go/go-crypto/Manifest
@@ -0,0 +1 @@
+DIST go-crypto-0_pre20150608.tar.gz 874125 SHA256 2980e16b13dbe52fd2f5128e06c664fe5712a52efa185fa3578d8abc6a124406 SHA512 6ad4e8ecf8c19c5428bd560b90a97bd7db084038e5afaa197a3d76349639e41ac3992e8bafe701b9f32e30ed63a6d0d511fd98cbcc2039f338f4bc174ad03e0e WHIRLPOOL d18fed06e4f2d4bdbde42aeaf02ece2a5c8264f1b222aadfe1c49f16ba814ab15f4d1d9f6050fbdd83825d7dec273e4f14ac95dae2db08ed7472a57fbb55e7bc
diff --git a/dev-go/go-crypto/go-crypto-0_pre20150608.ebuild b/dev-go/go-crypto/go-crypto-0_pre20150608.ebuild
new file mode 100644
index 000000000000..959bd7bde2bd
--- /dev/null
+++ b/dev-go/go-crypto/go-crypto-0_pre20150608.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go supplementary cryptography libraries"
+MY_PN=${PN##*-}
+GO_PN=golang.org/x/${MY_PN}
+HOMEPAGE="https://godoc.org/${GO_PN}"
+EGIT_COMMIT="1e856cbfdf9bc25eefca75f83f25d55e35ae72e0"
+SRC_URI="https://github.com/golang/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4"
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+EGIT_CHECKOUT_DIR="${S}"
+STRIP_MASK="*.a"
+
+src_unpack() {
+ default
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' -i ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i ssh/test/session_test.go || die
+}
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ GOROOT="${WORKDIR}/goroot"
+ cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN%/*}" \
+ "${GOROOT}/pkg/linux_${ARCH}/${GO_PN%/*}" || die
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
+}
+
+src_test() {
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} \
+ go test -x -v ${GO_PN}/... || die $?
+}
+
+src_install() {
+ insinto /usr/lib/go
+ find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ doins -r "${WORKDIR}"/{pkg,src}
+}
diff --git a/dev-go/go-crypto/go-crypto-9999.ebuild b/dev-go/go-crypto/go-crypto-9999.ebuild
new file mode 100644
index 000000000000..8601e78c875f
--- /dev/null
+++ b/dev-go/go-crypto/go-crypto-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=golang.org/x/crypto/...
+EGO_SRC=golang.org/x/crypto
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="1e856cbfdf9bc25eefca75f83f25d55e35ae72e0"
+ SRC_URI="https://github.com/golang/crypto/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go supplementary cryptography libraries"
+HOMEPAGE="https://godoc.org/golang.org/x/crypto"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/session_test.go || die
+}
diff --git a/dev-go/go-crypto/metadata.xml b/dev-go/go-crypto/metadata.xml
new file mode 100644
index 000000000000..4534f713bc8a
--- /dev/null
+++ b/dev-go/go-crypto/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">golang/crypto</remote-id>
+ </upstream>
+</pkgmetadata>