summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 10:44:45 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:05 -0500
commitec8478bdda1b7dc4f1ab541be1f253789ed14393 (patch)
treeb1e4fcfca5271d28a7a728b2d95e2701fe3387b2 /dev-gap/browse
parentdev-gap/spinsym: new package, add 1.5.2 (diff)
downloadgentoo-ec8478bdda1b7dc4f1ab541be1f253789ed14393.tar.gz
gentoo-ec8478bdda1b7dc4f1ab541be1f253789ed14393.tar.bz2
gentoo-ec8478bdda1b7dc4f1ab541be1f253789ed14393.zip
dev-gap/browse: new package, add 1.8.21
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap/browse')
-rw-r--r--dev-gap/browse/Manifest1
-rw-r--r--dev-gap/browse/browse-1.8.21.ebuild50
-rw-r--r--dev-gap/browse/metadata.xml31
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-gap/browse/Manifest b/dev-gap/browse/Manifest
new file mode 100644
index 000000000000..c1d07c96c615
--- /dev/null
+++ b/dev-gap/browse/Manifest
@@ -0,0 +1 @@
+DIST Browse-1.8.21.tar.gz 1830672 BLAKE2B b79dacba18c0d1ccea3a3ee30ad4c818b4e3727d336e05ab4958b14cc8556b5dfc32a6c529d0f001098e22c7f97eedd4aa26b617001c52884ea3b435ec40d995 SHA512 aba81e073c4c3cb7080c7ab28189ab7052f27d56927c8fde047f9ece71c42ff0eadf6cba42e0bc77f409082206f99987f4aff43226543e6f474b372f4d2104ff
diff --git a/dev-gap/browse/browse-1.8.21.ebuild b/dev-gap/browse/browse-1.8.21.ebuild
new file mode 100644
index 000000000000..d3dbaf838e5c
--- /dev/null
+++ b/dev-gap/browse/browse-1.8.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gap-pkg
+
+MY_PN=Browse
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="GAP ncurses interface for browsing two-dimensional data"
+SLOT="0"
+SRC_URI="https://www.math.rwth-aachen.de/homes/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+GAP_PKG_EXTRA_INSTALL=( app bibl )
+gap-pkg_enable_tests
+
+src_compile() {
+ # This has been emailed upstream but there's no public
+ # bug tracker AFAIK.
+ append-cflags -Wno-error=strict-prototypes
+ gap-pkg_src_compile
+}
+
+src_test() {
+ # TestPackage doesn't work for this guy. Copy the eclass src_test()
+ # and modify it to use TestDirectory() instead of TestPackage().
+ local gapcmd="gap -R -A --nointeract -c "
+ gapcmd+="LoadPackage(\"${PN}\");"
+ gapcmd+="d:=DirectoriesPackageLibrary(\"${PN}\",\"tst\");"
+ gapcmd+="TestDirectory(d[1],rec(exitGAP:=true));"
+ ln -s "${WORKDIR}" "${T}/pkg" || die
+ gapcmd+=" --roots ${T}/; "
+
+ # Even the "tee" pipe from the eclass isn't enough to stop
+ # this one from acting wacky, although it doesn't really
+ # break the terminal any more. Instead it just enters
+ # display mode and wipes your screen for a bit.
+ einfo "running test suite quietly to avoid borking your terminal"
+ ${gapcmd} > test-suite.log \
+ || die "test suite failed, see test-suite.log"
+}
diff --git a/dev-gap/browse/metadata.xml b/dev-gap/browse/metadata.xml
new file mode 100644
index 000000000000..9455e1e15ea5
--- /dev/null
+++ b/dev-gap/browse/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Browse package provides three levels of functionality:
+
+ 1 A GAP interface to the C-library ncurses.
+
+ 2 A generic function for interactive browsing through
+ two-dimensional arrays of data.
+
+ 3 Several applications of the first two, e.g., a method for
+ browsing character tables, browsing through the content of some
+ data collections, or some games.
+ </longdescription>
+</pkgmetadata>